History log of /freebsd-12.1/usr.sbin/rtsold/Makefile (Results 1 – 21 of 21)
Revision (<<< Hide revision tags) (Show revision tags >>>) Date Author Comments
Revision tags: release/12.2.0, release/11.4.0, release/12.1.0, release/11.3.0, release/12.0.0, release/11.2.0, release/10.4.0, release/11.1.0, release/11.0.1, release/11.0.0, release/10.3.0
# 56160b2e 06-Oct-2015 Xin LI <[email protected]>

Now that we own the code, use arc4random(3) unconditionally
and remove the corresponding HAVE_ARC4RANDOM conditions.

MFC after: 2 weeks


# f74237f5 10-Sep-2015 Hiroki Sato <[email protected]>

- Remove #ifdef HAVE_POLL_H.
- Use nitems().

MFC after: 3 days


Revision tags: release/10.2.0
# 933095de 09-Apr-2015 Baptiste Daroussin <[email protected]>

rtsold does not need to link to libkvm


# c6db8143 25-Nov-2014 Baptiste Daroussin <[email protected]>

Convert usr.sbin to LIBADD
Reduce overlinking


Revision tags: release/10.1.0, release/9.3.0, release/10.0.0, release/9.2.0, release/8.4.0, release/9.1.0, release/8.3.0
# 1d90532a 07-Jun-2011 Marcel Moolenaar <[email protected]>

Lower WARNS level to 3 to eliminate alignment warnings related to
casting inherent in CMSG_DATA().


# 48a16a34 06-Jun-2011 Ed Schouten <[email protected]>

Remove redundant assignments to WARNS.

For these directories, WARNS is already implied to be 6.


# db82af41 06-Jun-2011 Hiroki Sato <[email protected]>

- Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement
Options for DNS Configuration) into rtadvd(8) and rtsold(8). DNS
information received by rtsold(8) will go to resolv.conf

- Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement
Options for DNS Configuration) into rtadvd(8) and rtsold(8). DNS
information received by rtsold(8) will go to resolv.conf(5) by
resolvconf(8) script. This is based on work by J.R. Oldroyd (kern/156259)
but revised extensively[1].

- rtadvd(8) now supports "noifprefix" to disable gathering on-link prefixes
from interfaces when no "addr" is specified[2]. An entry in rtadvd.conf
with "noifprefix" + no "addr" generates an RA message with no prefix
information option.

- rtadvd(8) now supports RTM_IFANNOUNCE message to fix crashes when an
interface is added or removed.

- Correct bogus ND_OPT_ROUTE_INFO value to one in RFC 4191.

Reviewed by: bz[1]
PR: kern/156259 [1]
PR: bin/152458 [2]

show more ...


Revision tags: release/7.4.0, release/8.2.0, release/8.1.0, release/7.3.0
# bd2c49af 27-Feb-2010 Ulrich Spörlein <[email protected]>

rtsol(8)/rtsold(8): make WARNS=3 clean

It is actually WARNS=6 clean for non-strict alignment archs.

Approved by: ed (co-mentor)


# 71ccf092 02-Jan-2010 Ed Schouten <[email protected]>

The last big commit: let usr.sbin/ use WARNS=6 by default.


Revision tags: release/8.0.0, release/7.2.0, release/7.1.0, release/6.4.0, release/7.0.0, release/6.3.0, release/6.2.0
# 064aa447 27-Jul-2006 Yaroslav Tykhiy <[email protected]>

These IPv6-only tools have no explicit dependency on the INET6 macro.

Tested with: cmp(1)


Revision tags: release/5.5.0, release/6.1.0, release/6.0.0, release/5.4.0, release/4.11.0, release/5.3.0, release/4.10.0, release/5.2.1, release/5.2.0, release/4.9.0
# 5c706347 14-Aug-2003 Hajimu UMEMOTO <[email protected]>

support poll(2).

Obtained from: KAME
MFC after: 1 week


# 5ed8c16b 08-Aug-2003 Hajimu UMEMOTO <[email protected]>

drop the code for the environment where getifaddrs(3) is not
supported.

Obtained from: KAME
MFC after: 1 week


Revision tags: release/5.1.0
# 052238b1 04-Apr-2003 David E. O'Brien <[email protected]>

style.Makefile(5)


Revision tags: release/4.8.0
# 21c7f9f0 11-Feb-2003 Andrey A. Chernov <[email protected]>

Add -DHAVE_ARC4RANDOM to CFLAGS


Revision tags: release/5.0.0, release/4.6.2
# 90e655ea 20-Jul-2001 David E. O'Brien <[email protected]>

Perform a major cleanup of the usr.sbin Makefiles.
These are not perfectly in agreement with each other style-wise, but they
are orders of orders of magnitude more consistent style-wise than before.


# 33841545 11-Jun-2001 Hajimu UMEMOTO <[email protected]>

Sync with recent KAME.
This work was based on kame-20010528-freebsd43-snap.tgz and some
critical problem after the snap was out were fixed.
There are many many changes since last KAME merge.

TODO:

Sync with recent KAME.
This work was based on kame-20010528-freebsd43-snap.tgz and some
critical problem after the snap was out were fixed.
There are many many changes since last KAME merge.

TODO:
- The definitions of SADB_* in sys/net/pfkeyv2.h are still different
from RFC2407/IANA assignment because of binary compatibility
issue. It should be fixed under 5-CURRENT.
- ip6po_m member of struct ip6_pktopts is no longer used. But, it
is still there because of binary compatibility issue. It should
be removed under 5-CURRENT.

Reviewed by: itojun
Obtained from: KAME
MFC after: 3 weeks

show more ...


Revision tags: release/4.3.0
# 345e52e7 26-Mar-2001 Ruslan Ermilov <[email protected]>

- Backout botched attempt to introduce MANSECT feature.
- MAN[1-9] -> MAN.


# c73e22c3 20-Mar-2001 Ruslan Ermilov <[email protected]>

Set the default manual section for usr.sbin/ to 8.


# 8b158403 06-Jul-2000 Kris Kennaway <[email protected]>

Correct style bugs


# 259df286 05-Jul-2000 Kris Kennaway <[email protected]>

Sync with latest KAME.

Obtained from: KAME


# 7d56d374 28-Dec-1999 Yoshinobu Inoue <[email protected]>

Getaddrinfo(), getnameinfo(), and etc support in libc/net.
Several udp and raw apps IPv6 support.

Reviewed by: freebsd-arch, cvs-committers
Obtained from: KAME project