|
Revision tags: release/12.2.0, release/11.4.0, release/12.1.0, release/11.3.0, release/12.0.0, release/11.2.0, release/10.4.0, release/11.1.0, release/11.0.1, release/11.0.0, release/10.3.0 |
|
| #
56160b2e |
| 06-Oct-2015 |
Xin LI <[email protected]> |
Now that we own the code, use arc4random(3) unconditionally and remove the corresponding HAVE_ARC4RANDOM conditions.
MFC after: 2 weeks
|
|
Revision tags: release/10.2.0 |
|
| #
c6db8143 |
| 25-Nov-2014 |
Baptiste Daroussin <[email protected]> |
Convert usr.sbin to LIBADD Reduce overlinking
|
|
Revision tags: release/10.1.0, release/9.3.0, release/10.0.0, release/9.2.0, release/8.4.0, release/9.1.0, release/8.3.0 |
|
| #
37241896 |
| 17-Jul-2011 |
Hiroki Sato <[email protected]> |
- Improve interface list handling. The rtadvd(8) now supports dynamically- added/removed interfaces in a more consistent manner and reloading the configuration file.
- Implement burst unsolicit
- Improve interface list handling. The rtadvd(8) now supports dynamically- added/removed interfaces in a more consistent manner and reloading the configuration file.
- Implement burst unsolicited RA sending into the internal RA timer framework when AdvSendAdvertisements and/or configuration entries are changed as described in RFC 4861 6.2.4. This fixes issues that make termination of the rtadvd(8) daemon take very long time.
An interface now has three internal states, UNCONFIGURED, TRANSITIVE, or CONFIGURED, and the burst unsolicited sending happens in TRANSITIVE. See rtadvd.h for the details.
- rtadvd(8) now accepts non-existent interfaces as well in the command line.
- Add control socket support and rtadvctl(8) utility to show the RA information in rtadvd(8). Dumping by SIGUSR1 has been removed in favor of it.
show more ...
|
| #
37a0ad80 |
| 06-Jun-2011 |
Hiroki Sato <[email protected]> |
Set WARNS=1 temporarily to unbreak universe.
|
| #
db82af41 |
| 06-Jun-2011 |
Hiroki Sato <[email protected]> |
- Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement Options for DNS Configuration) into rtadvd(8) and rtsold(8). DNS information received by rtsold(8) will go to resolv.conf
- Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement Options for DNS Configuration) into rtadvd(8) and rtsold(8). DNS information received by rtsold(8) will go to resolv.conf(5) by resolvconf(8) script. This is based on work by J.R. Oldroyd (kern/156259) but revised extensively[1].
- rtadvd(8) now supports "noifprefix" to disable gathering on-link prefixes from interfaces when no "addr" is specified[2]. An entry in rtadvd.conf with "noifprefix" + no "addr" generates an RA message with no prefix information option.
- rtadvd(8) now supports RTM_IFANNOUNCE message to fix crashes when an interface is added or removed.
- Correct bogus ND_OPT_ROUTE_INFO value to one in RFC 4191.
Reviewed by: bz[1] PR: kern/156259 [1] PR: bin/152458 [2]
show more ...
|
|
Revision tags: release/7.4.0, release/8.2.0 |
|
| #
24f2cbe9 |
| 23-Dec-2010 |
Xin LI <[email protected]> |
style.Makefile says tab between var= and value.
|
| #
f49f3df8 |
| 22-Dec-2010 |
Xin LI <[email protected]> |
Allow overriding pidfile and dumpfile.
PR: bin/153362 Submitted by: Joe Holden <joe rewt org uk> MFC after: 1 month
|
|
Revision tags: release/8.1.0, release/7.3.0 |
|
| #
71ccf092 |
| 02-Jan-2010 |
Ed Schouten <[email protected]> |
The last big commit: let usr.sbin/ use WARNS=6 by default.
|
|
Revision tags: release/8.0.0, release/7.2.0, release/7.1.0, release/6.4.0, release/7.0.0, release/6.3.0, release/6.2.0 |
|
| #
064aa447 |
| 27-Jul-2006 |
Yaroslav Tykhiy <[email protected]> |
These IPv6-only tools have no explicit dependency on the INET6 macro.
Tested with: cmp(1)
|
|
Revision tags: release/5.5.0, release/6.1.0, release/6.0.0, release/5.4.0, release/4.11.0, release/5.3.0 |
|
| #
18598252 |
| 21-Jun-2004 |
Poul-Henning Kamp <[email protected]> |
libcompat doesn't seem to be necessary any more.
|
|
Revision tags: release/4.10.0, release/5.2.1, release/5.2.0, release/4.9.0 |
|
| #
fc35a81b |
| 15-Aug-2003 |
Hajimu UMEMOTO <[email protected]> |
- supported a string notation for xxflags. - deprecate routes#N, as it is hard to keep consistency with rtprefixN. accept any number of "rtprefix", "rtrefix0", ..., "rtprefix99". - deprecate "ad
- supported a string notation for xxflags. - deprecate routes#N, as it is hard to keep consistency with rtprefixN. accept any number of "rtprefix", "rtrefix0", ..., "rtprefix99". - deprecate "addrs#N", as it is difficult for users to keep consistency with "addrN". accept 100 prefix info in maximum - like "addr", "addr0" ... "addr99". WARNS=2 clean on netbsd. old configuration file should work just fine. behavior change: previously, we rejected "addrN" if there's "addr", and we rejected "addr" if there is "addrN". now we accept both without problem. - when an advertised prefix configured from the kernel has been added or invalidated, notice the change in a short delay. - when invalidating a prefix, do not bark even if there is inconsistency about prefix lifetimes. - wrap more specific route info code into ROUTEINFO.
Obtained from: KAME MFC after: 1 week
show more ...
|
| #
dba14c30 |
| 15-Aug-2003 |
Hajimu UMEMOTO <[email protected]> |
use arc4random.
Obtained from: KAME MFC after: 1 week
|
| #
5c706347 |
| 14-Aug-2003 |
Hajimu UMEMOTO <[email protected]> |
support poll(2).
Obtained from: KAME MFC after: 1 week
|
|
Revision tags: release/5.1.0 |
|
| #
052238b1 |
| 04-Apr-2003 |
David E. O'Brien <[email protected]> |
style.Makefile(5)
|
|
Revision tags: release/4.8.0, release/5.0.0, release/4.6.2 |
|
| #
90e655ea |
| 20-Jul-2001 |
David E. O'Brien <[email protected]> |
Perform a major cleanup of the usr.sbin Makefiles. These are not perfectly in agreement with each other style-wise, but they are orders of orders of magnitude more consistent style-wise than before.
|
|
Revision tags: release/4.3.0 |
|
| #
345e52e7 |
| 26-Mar-2001 |
Ruslan Ermilov <[email protected]> |
- Backout botched attempt to introduce MANSECT feature. - MAN[1-9] -> MAN.
|
| #
b26e03e9 |
| 05-Jul-2000 |
Kris Kennaway <[email protected]> |
Sync with latest KAME
Obtained from: KAME
|
| #
9a4365d0 |
| 06-Jan-2000 |
Yoshinobu Inoue <[email protected]> |
libipsec and IPsec related apps. (and some KAME related man pages)
Reviewed by: freebsd-arch, cvs-committers Obtained from: KAME project
|