1 #ifndef INCLUDED_HTTP_KV_H 2 #define INCLUDED_HTTP_KV_H 3 #include "first.h" 4 5 #include "buffer.h" 6 7 /* sources: 8 * - [RFC2616], Section 9 9 * (or http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-22) 10 * - http://tools.ietf.org/html/draft-ietf-httpbis-method-registrations-11, Appendix A 11 * 12 * http://tools.ietf.org/html/draft-ietf-httpbis-p2-semantics-22, Section 8.1 defines 13 * a new registry (not available yet): 14 * http://www.iana.org/assignments/http-methods 15 */ 16 17 typedef enum { 18 HTTP_METHOD_PRI = -2, /* [RFC7540], Section 3.5 */ 19 HTTP_METHOD_UNSET = -1, 20 HTTP_METHOD_GET, /* [RFC2616], Section 9.3 */ 21 HTTP_METHOD_HEAD, /* [RFC2616], Section 9.4 */ 22 HTTP_METHOD_POST, /* [RFC2616], Section 9.5 */ 23 HTTP_METHOD_PUT, /* [RFC2616], Section 9.6 */ 24 HTTP_METHOD_DELETE, /* [RFC2616], Section 9.7 */ 25 HTTP_METHOD_CONNECT, /* [RFC2616], Section 9.9 */ 26 HTTP_METHOD_OPTIONS, /* [RFC2616], Section 9.2 */ 27 HTTP_METHOD_TRACE, /* [RFC2616], Section 9.8 */ 28 HTTP_METHOD_ACL, /* [RFC3744], Section 8.1 */ 29 HTTP_METHOD_BASELINE_CONTROL, /* [RFC3253], Section 12.6 */ 30 HTTP_METHOD_BIND, /* [RFC5842], Section 4 */ 31 HTTP_METHOD_CHECKIN, /* [RFC3253], Section 4.4 and [RFC3253], Section 9.4 */ 32 HTTP_METHOD_CHECKOUT, /* [RFC3253], Section 4.3 and [RFC3253], Section 8.8 */ 33 HTTP_METHOD_COPY, /* [RFC4918], Section 9.8 */ 34 HTTP_METHOD_LABEL, /* [RFC3253], Section 8.2 */ 35 HTTP_METHOD_LINK, /* [RFC2068], Section 19.6.1.2 */ 36 HTTP_METHOD_LOCK, /* [RFC4918], Section 9.10 */ 37 HTTP_METHOD_MERGE, /* [RFC3253], Section 11.2 */ 38 HTTP_METHOD_MKACTIVITY, /* [RFC3253], Section 13.5 */ 39 HTTP_METHOD_MKCALENDAR, /* [RFC4791], Section 5.3.1 */ 40 HTTP_METHOD_MKCOL, /* [RFC4918], Section 9.3 */ 41 HTTP_METHOD_MKREDIRECTREF, /* [RFC4437], Section 6 */ 42 HTTP_METHOD_MKWORKSPACE, /* [RFC3253], Section 6.3 */ 43 HTTP_METHOD_MOVE, /* [RFC4918], Section 9.9 */ 44 HTTP_METHOD_ORDERPATCH, /* [RFC3648], Section 7 */ 45 HTTP_METHOD_PATCH, /* [RFC5789], Section 2 */ 46 HTTP_METHOD_PROPFIND, /* [RFC4918], Section 9.1 */ 47 HTTP_METHOD_PROPPATCH, /* [RFC4918], Section 9.2 */ 48 HTTP_METHOD_REBIND, /* [RFC5842], Section 6 */ 49 HTTP_METHOD_REPORT, /* [RFC3253], Section 3.6 */ 50 HTTP_METHOD_SEARCH, /* [RFC5323], Section 2 */ 51 HTTP_METHOD_UNBIND, /* [RFC5842], Section 5 */ 52 HTTP_METHOD_UNCHECKOUT, /* [RFC3253], Section 4.5 */ 53 HTTP_METHOD_UNLINK, /* [RFC2068], Section 19.6.1.3 */ 54 HTTP_METHOD_UNLOCK, /* [RFC4918], Section 9.11 */ 55 HTTP_METHOD_UPDATE, /* [RFC3253], Section 7.1 */ 56 HTTP_METHOD_UPDATEREDIRECTREF, /* [RFC4437], Section 7 */ 57 HTTP_METHOD_VERSION_CONTROL /* [RFC3253], Section 3.5 */ 58 } http_method_t; 59 60 typedef enum { HTTP_VERSION_UNSET = -1, HTTP_VERSION_1_0, HTTP_VERSION_1_1, HTTP_VERSION_2 } http_version_t; 61 62 #if 0 /*(unused)*/ 63 __attribute_pure__ 64 const char *get_http_status_name(int i); 65 #endif 66 67 __attribute_pure__ 68 const char *get_http_version_name(int i); 69 70 /*(deprecated)*/ 71 #define get_http_method_name(i) http_method_buf(i)->ptr 72 73 #if 0 /*(unused)*/ 74 __attribute_nonnull__ 75 __attribute_pure__ 76 int get_http_version_key(const char *s, size_t slen); 77 #endif 78 79 __attribute_pure__ 80 const buffer *http_method_buf (http_method_t i); 81 82 __attribute_nonnull__ 83 __attribute_pure__ 84 http_method_t get_http_method_key(const char *s, size_t slen); 85 86 __attribute_nonnull__ 87 void http_status_append(buffer *b, int status); 88 89 __attribute_nonnull__ 90 void http_version_append(buffer *b, http_version_t version); 91 92 #define http_method_get_or_head(method) ((method) <= HTTP_METHOD_HEAD) 93 #define http_method_get_head_post(method) ((method) <= HTTP_METHOD_POST) 94 95 __attribute_nonnull__ 96 static inline void http_method_append (buffer * const b, const http_method_t method); 97 static inline void http_method_append (buffer * const b, const http_method_t method) { 98 const buffer * const kv = http_method_buf(method); 99 buffer_append_string_len(b, BUF_PTR_LEN(kv)); 100 } 101 102 103 #endif 104