1 /* $FreeBSD$ */
2 /* $OpenBSD: ip_esp.c,v 1.69 2001/06/26 06:18:59 angelos Exp $ */
3 /*-
4 * The authors of this code are John Ioannidis ([email protected]),
5 * Angelos D. Keromytis ([email protected]) and
6 * Niels Provos ([email protected]).
7 *
8 * The original version of this code was written by John Ioannidis
9 * for BSD/OS in Athens, Greece, in November 1995.
10 *
11 * Ported to OpenBSD and NetBSD, with additional transforms, in December 1996,
12 * by Angelos D. Keromytis.
13 *
14 * Additional transforms and features in 1997 and 1998 by Angelos D. Keromytis
15 * and Niels Provos.
16 *
17 * Additional features in 1999 by Angelos D. Keromytis.
18 *
19 * Copyright (C) 1995, 1996, 1997, 1998, 1999 by John Ioannidis,
20 * Angelos D. Keromytis and Niels Provos.
21 * Copyright (c) 2001 Angelos D. Keromytis.
22 *
23 * Permission to use, copy, and modify this software with or without fee
24 * is hereby granted, provided that this entire notice is included in
25 * all copies of any software which is or includes a copy or
26 * modification of this software.
27 * You may use this code under the GNU public license if you so wish. Please
28 * contribute changes back to the authors under this freer than GPL license
29 * so that we may further the use of strong encryption without limitations to
30 * all.
31 *
32 * THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR
33 * IMPLIED WARRANTY. IN PARTICULAR, NONE OF THE AUTHORS MAKES ANY
34 * REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE
35 * MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR
36 * PURPOSE.
37 */
38 #include "opt_inet.h"
39 #include "opt_inet6.h"
40
41 #include <sys/param.h>
42 #include <sys/systm.h>
43 #include <sys/mbuf.h>
44 #include <sys/socket.h>
45 #include <sys/syslog.h>
46 #include <sys/kernel.h>
47 #include <sys/lock.h>
48 #include <sys/random.h>
49 #include <sys/mutex.h>
50 #include <sys/sysctl.h>
51 #include <sys/mutex.h>
52 #include <machine/atomic.h>
53
54 #include <net/if.h>
55 #include <net/vnet.h>
56
57 #include <netinet/in.h>
58 #include <netinet/in_systm.h>
59 #include <netinet/ip.h>
60 #include <netinet/ip_ecn.h>
61 #include <netinet/ip6.h>
62
63 #include <netipsec/ipsec.h>
64 #include <netipsec/ah.h>
65 #include <netipsec/ah_var.h>
66 #include <netipsec/esp.h>
67 #include <netipsec/esp_var.h>
68 #include <netipsec/xform.h>
69
70 #ifdef INET6
71 #include <netinet6/ip6_var.h>
72 #include <netipsec/ipsec6.h>
73 #include <netinet6/ip6_ecn.h>
74 #endif
75
76 #include <netipsec/key.h>
77 #include <netipsec/key_debug.h>
78
79 #include <opencrypto/cryptodev.h>
80 #include <opencrypto/xform.h>
81
82 VNET_DEFINE(int, esp_enable) = 1;
83 VNET_PCPUSTAT_DEFINE(struct espstat, espstat);
84 VNET_PCPUSTAT_SYSINIT(espstat);
85
86 #ifdef VIMAGE
87 VNET_PCPUSTAT_SYSUNINIT(espstat);
88 #endif /* VIMAGE */
89
90 SYSCTL_DECL(_net_inet_esp);
91 SYSCTL_INT(_net_inet_esp, OID_AUTO, esp_enable,
92 CTLFLAG_VNET | CTLFLAG_RW, &VNET_NAME(esp_enable), 0, "");
93 SYSCTL_VNET_PCPUSTAT(_net_inet_esp, IPSECCTL_STATS, stats,
94 struct espstat, espstat,
95 "ESP statistics (struct espstat, netipsec/esp_var.h");
96
97 static struct timeval deswarn, blfwarn, castwarn, camelliawarn;
98
99 static int esp_input_cb(struct cryptop *op);
100 static int esp_output_cb(struct cryptop *crp);
101
102 size_t
esp_hdrsiz(struct secasvar * sav)103 esp_hdrsiz(struct secasvar *sav)
104 {
105 size_t size;
106
107 if (sav != NULL) {
108 /*XXX not right for null algorithm--does it matter??*/
109 IPSEC_ASSERT(sav->tdb_encalgxform != NULL,
110 ("SA with null xform"));
111 if (sav->flags & SADB_X_EXT_OLD)
112 size = sizeof (struct esp);
113 else
114 size = sizeof (struct newesp);
115 size += sav->tdb_encalgxform->blocksize + 9;
116 /*XXX need alg check???*/
117 if (sav->tdb_authalgxform != NULL && sav->replay)
118 size += ah_hdrsiz(sav);
119 } else {
120 /*
121 * base header size
122 * + max iv length for CBC mode
123 * + max pad length
124 * + sizeof (pad length field)
125 * + sizeof (next header field)
126 * + max icv supported.
127 */
128 size = sizeof (struct newesp) + EALG_MAX_BLOCK_LEN + 9 + 16;
129 }
130 return size;
131 }
132
133 /*
134 * esp_init() is called when an SPI is being set up.
135 */
136 static int
esp_init(struct secasvar * sav,struct xformsw * xsp)137 esp_init(struct secasvar *sav, struct xformsw *xsp)
138 {
139 const struct enc_xform *txform;
140 struct cryptoini cria, crie;
141 int keylen;
142 int error;
143
144 txform = enc_algorithm_lookup(sav->alg_enc);
145 if (txform == NULL) {
146 DPRINTF(("%s: unsupported encryption algorithm %d\n",
147 __func__, sav->alg_enc));
148 return EINVAL;
149 }
150 if (sav->key_enc == NULL) {
151 DPRINTF(("%s: no encoding key for %s algorithm\n",
152 __func__, txform->name));
153 return EINVAL;
154 }
155 if ((sav->flags & (SADB_X_EXT_OLD | SADB_X_EXT_IV4B)) ==
156 SADB_X_EXT_IV4B) {
157 DPRINTF(("%s: 4-byte IV not supported with protocol\n",
158 __func__));
159 return EINVAL;
160 }
161
162 switch (sav->alg_enc) {
163 case SADB_EALG_DESCBC:
164 if (ratecheck(&deswarn, &ipsec_warn_interval))
165 gone_in(13, "DES cipher for IPsec");
166 break;
167 case SADB_X_EALG_BLOWFISHCBC:
168 if (ratecheck(&blfwarn, &ipsec_warn_interval))
169 gone_in(13, "Blowfish cipher for IPsec");
170 break;
171 case SADB_X_EALG_CAST128CBC:
172 if (ratecheck(&castwarn, &ipsec_warn_interval))
173 gone_in(13, "CAST cipher for IPsec");
174 break;
175 case SADB_X_EALG_CAMELLIACBC:
176 if (ratecheck(&camelliawarn, &ipsec_warn_interval))
177 gone_in(13, "Camellia cipher for IPsec");
178 break;
179 }
180
181 /* subtract off the salt, RFC4106, 8.1 and RFC3686, 5.1 */
182 keylen = _KEYLEN(sav->key_enc) - SAV_ISCTRORGCM(sav) * 4;
183 if (txform->minkey > keylen || keylen > txform->maxkey) {
184 DPRINTF(("%s: invalid key length %u, must be in the range "
185 "[%u..%u] for algorithm %s\n", __func__,
186 keylen, txform->minkey, txform->maxkey,
187 txform->name));
188 return EINVAL;
189 }
190
191 if (SAV_ISCTRORGCM(sav))
192 sav->ivlen = 8; /* RFC4106 3.1 and RFC3686 3.1 */
193 else
194 sav->ivlen = txform->ivsize;
195
196 /*
197 * Setup AH-related state.
198 */
199 if (sav->alg_auth != 0) {
200 error = ah_init0(sav, xsp, &cria);
201 if (error)
202 return error;
203 }
204
205 /* NB: override anything set in ah_init0 */
206 sav->tdb_xform = xsp;
207 sav->tdb_encalgxform = txform;
208
209 /*
210 * Whenever AES-GCM is used for encryption, one
211 * of the AES authentication algorithms is chosen
212 * as well, based on the key size.
213 */
214 if (sav->alg_enc == SADB_X_EALG_AESGCM16) {
215 switch (keylen) {
216 case AES_128_GMAC_KEY_LEN:
217 sav->alg_auth = SADB_X_AALG_AES128GMAC;
218 sav->tdb_authalgxform = &auth_hash_nist_gmac_aes_128;
219 break;
220 case AES_192_GMAC_KEY_LEN:
221 sav->alg_auth = SADB_X_AALG_AES192GMAC;
222 sav->tdb_authalgxform = &auth_hash_nist_gmac_aes_192;
223 break;
224 case AES_256_GMAC_KEY_LEN:
225 sav->alg_auth = SADB_X_AALG_AES256GMAC;
226 sav->tdb_authalgxform = &auth_hash_nist_gmac_aes_256;
227 break;
228 default:
229 DPRINTF(("%s: invalid key length %u"
230 "for algorithm %s\n", __func__,
231 keylen, txform->name));
232 return EINVAL;
233 }
234 bzero(&cria, sizeof(cria));
235 cria.cri_alg = sav->tdb_authalgxform->type;
236 cria.cri_key = sav->key_enc->key_data;
237 cria.cri_klen = _KEYBITS(sav->key_enc) - SAV_ISGCM(sav) * 32;
238 }
239
240 /* Initialize crypto session. */
241 bzero(&crie, sizeof(crie));
242 crie.cri_alg = sav->tdb_encalgxform->type;
243 crie.cri_key = sav->key_enc->key_data;
244 crie.cri_klen = _KEYBITS(sav->key_enc) - SAV_ISCTRORGCM(sav) * 32;
245
246 if (sav->tdb_authalgxform && sav->tdb_encalgxform) {
247 /* init both auth & enc */
248 crie.cri_next = &cria;
249 error = crypto_newsession(&sav->tdb_cryptoid,
250 &crie, V_crypto_support);
251 } else if (sav->tdb_encalgxform) {
252 error = crypto_newsession(&sav->tdb_cryptoid,
253 &crie, V_crypto_support);
254 } else if (sav->tdb_authalgxform) {
255 error = crypto_newsession(&sav->tdb_cryptoid,
256 &cria, V_crypto_support);
257 } else {
258 /* XXX cannot happen? */
259 DPRINTF(("%s: no encoding OR authentication xform!\n",
260 __func__));
261 error = EINVAL;
262 }
263 return error;
264 }
265
266 /*
267 * Paranoia.
268 */
269 static int
esp_zeroize(struct secasvar * sav)270 esp_zeroize(struct secasvar *sav)
271 {
272 /* NB: ah_zerorize free's the crypto session state */
273 int error = ah_zeroize(sav);
274
275 if (sav->key_enc)
276 bzero(sav->key_enc->key_data, _KEYLEN(sav->key_enc));
277 sav->tdb_encalgxform = NULL;
278 sav->tdb_xform = NULL;
279 return error;
280 }
281
282 /*
283 * ESP input processing, called (eventually) through the protocol switch.
284 */
285 static int
esp_input(struct mbuf * m,struct secasvar * sav,int skip,int protoff)286 esp_input(struct mbuf *m, struct secasvar *sav, int skip, int protoff)
287 {
288 IPSEC_DEBUG_DECLARE(char buf[128]);
289 const struct auth_hash *esph;
290 const struct enc_xform *espx;
291 struct xform_data *xd;
292 struct cryptodesc *crde;
293 struct cryptop *crp;
294 struct newesp *esp;
295 uint8_t *ivp;
296 crypto_session_t cryptoid;
297 int alen, error, hlen, plen;
298
299 IPSEC_ASSERT(sav != NULL, ("null SA"));
300 IPSEC_ASSERT(sav->tdb_encalgxform != NULL, ("null encoding xform"));
301
302 error = EINVAL;
303 /* Valid IP Packet length ? */
304 if ( (skip&3) || (m->m_pkthdr.len&3) ){
305 DPRINTF(("%s: misaligned packet, skip %u pkt len %u",
306 __func__, skip, m->m_pkthdr.len));
307 ESPSTAT_INC(esps_badilen);
308 goto bad;
309 }
310 /* XXX don't pullup, just copy header */
311 IP6_EXTHDR_GET(esp, struct newesp *, m, skip, sizeof (struct newesp));
312
313 esph = sav->tdb_authalgxform;
314 espx = sav->tdb_encalgxform;
315
316 /* Determine the ESP header and auth length */
317 if (sav->flags & SADB_X_EXT_OLD)
318 hlen = sizeof (struct esp) + sav->ivlen;
319 else
320 hlen = sizeof (struct newesp) + sav->ivlen;
321
322 alen = xform_ah_authsize(esph);
323
324 /*
325 * Verify payload length is multiple of encryption algorithm
326 * block size.
327 *
328 * NB: This works for the null algorithm because the blocksize
329 * is 4 and all packets must be 4-byte aligned regardless
330 * of the algorithm.
331 */
332 plen = m->m_pkthdr.len - (skip + hlen + alen);
333 if ((plen & (espx->blocksize - 1)) || (plen <= 0)) {
334 DPRINTF(("%s: payload of %d octets not a multiple of %d octets,"
335 " SA %s/%08lx\n", __func__, plen, espx->blocksize,
336 ipsec_address(&sav->sah->saidx.dst, buf, sizeof(buf)),
337 (u_long)ntohl(sav->spi)));
338 ESPSTAT_INC(esps_badilen);
339 goto bad;
340 }
341
342 /*
343 * Check sequence number.
344 */
345 SECASVAR_LOCK(sav);
346 if (esph != NULL && sav->replay != NULL && sav->replay->wsize != 0) {
347 if (ipsec_chkreplay(ntohl(esp->esp_seq), sav) == 0) {
348 SECASVAR_UNLOCK(sav);
349 DPRINTF(("%s: packet replay check for %s\n", __func__,
350 ipsec_sa2str(sav, buf, sizeof(buf))));
351 ESPSTAT_INC(esps_replay);
352 error = EACCES;
353 goto bad;
354 }
355 }
356 cryptoid = sav->tdb_cryptoid;
357 SECASVAR_UNLOCK(sav);
358
359 /* Update the counters */
360 ESPSTAT_ADD(esps_ibytes, m->m_pkthdr.len - (skip + hlen + alen));
361
362 /* Get crypto descriptors */
363 crp = crypto_getreq(esph && espx ? 2 : 1);
364 if (crp == NULL) {
365 DPRINTF(("%s: failed to acquire crypto descriptors\n",
366 __func__));
367 ESPSTAT_INC(esps_crypto);
368 error = ENOBUFS;
369 goto bad;
370 }
371
372 /* Get IPsec-specific opaque pointer */
373 xd = malloc(sizeof(*xd) + alen, M_XDATA, M_NOWAIT | M_ZERO);
374 if (xd == NULL) {
375 DPRINTF(("%s: failed to allocate xform_data\n", __func__));
376 ESPSTAT_INC(esps_crypto);
377 crypto_freereq(crp);
378 error = ENOBUFS;
379 goto bad;
380 }
381
382 if (esph != NULL) {
383 struct cryptodesc *crda = crp->crp_desc;
384
385 IPSEC_ASSERT(crda != NULL, ("null ah crypto descriptor"));
386
387 /* Authentication descriptor */
388 crda->crd_skip = skip;
389 if (SAV_ISGCM(sav))
390 crda->crd_len = 8; /* RFC4106 5, SPI + SN */
391 else
392 crda->crd_len = m->m_pkthdr.len - (skip + alen);
393 crda->crd_inject = m->m_pkthdr.len - alen;
394
395 crda->crd_alg = esph->type;
396
397 /* Copy the authenticator */
398 m_copydata(m, m->m_pkthdr.len - alen, alen,
399 (caddr_t) (xd + 1));
400
401 /* Chain authentication request */
402 crde = crda->crd_next;
403 } else {
404 crde = crp->crp_desc;
405 }
406
407 /* Crypto operation descriptor */
408 crp->crp_ilen = m->m_pkthdr.len; /* Total input length */
409 crp->crp_flags = CRYPTO_F_IMBUF | CRYPTO_F_CBIFSYNC;
410 if (V_async_crypto)
411 crp->crp_flags |= CRYPTO_F_ASYNC | CRYPTO_F_ASYNC_KEEPORDER;
412 crp->crp_buf = (caddr_t) m;
413 crp->crp_callback = esp_input_cb;
414 crp->crp_session = cryptoid;
415 crp->crp_opaque = (caddr_t) xd;
416
417 /* These are passed as-is to the callback */
418 xd->sav = sav;
419 xd->protoff = protoff;
420 xd->skip = skip;
421 xd->cryptoid = cryptoid;
422 xd->vnet = curvnet;
423
424 /* Decryption descriptor */
425 IPSEC_ASSERT(crde != NULL, ("null esp crypto descriptor"));
426 crde->crd_skip = skip + hlen;
427 crde->crd_len = m->m_pkthdr.len - (skip + hlen + alen);
428 crde->crd_inject = skip + hlen - sav->ivlen;
429
430 if (SAV_ISCTRORGCM(sav)) {
431 ivp = &crde->crd_iv[0];
432
433 /* GCM IV Format: RFC4106 4 */
434 /* CTR IV Format: RFC3686 4 */
435 /* Salt is last four bytes of key, RFC4106 8.1 */
436 /* Nonce is last four bytes of key, RFC3686 5.1 */
437 memcpy(ivp, sav->key_enc->key_data +
438 _KEYLEN(sav->key_enc) - 4, 4);
439
440 if (SAV_ISCTR(sav)) {
441 /* Initial block counter is 1, RFC3686 4 */
442 be32enc(&ivp[sav->ivlen + 4], 1);
443 }
444
445 m_copydata(m, skip + hlen - sav->ivlen, sav->ivlen, &ivp[4]);
446 crde->crd_flags |= CRD_F_IV_EXPLICIT;
447 }
448
449 crde->crd_alg = espx->type;
450
451 return (crypto_dispatch(crp));
452 bad:
453 m_freem(m);
454 key_freesav(&sav);
455 return (error);
456 }
457
458 /*
459 * ESP input callback from the crypto driver.
460 */
461 static int
esp_input_cb(struct cryptop * crp)462 esp_input_cb(struct cryptop *crp)
463 {
464 IPSEC_DEBUG_DECLARE(char buf[128]);
465 u_int8_t lastthree[3], aalg[AH_HMAC_MAXHASHLEN];
466 const struct auth_hash *esph;
467 struct mbuf *m;
468 struct cryptodesc *crd;
469 struct xform_data *xd;
470 struct secasvar *sav;
471 struct secasindex *saidx;
472 caddr_t ptr;
473 crypto_session_t cryptoid;
474 int hlen, skip, protoff, error, alen;
475
476 crd = crp->crp_desc;
477 IPSEC_ASSERT(crd != NULL, ("null crypto descriptor!"));
478
479 m = (struct mbuf *) crp->crp_buf;
480 xd = (struct xform_data *) crp->crp_opaque;
481 CURVNET_SET(xd->vnet);
482 sav = xd->sav;
483 skip = xd->skip;
484 protoff = xd->protoff;
485 cryptoid = xd->cryptoid;
486 saidx = &sav->sah->saidx;
487 esph = sav->tdb_authalgxform;
488
489 /* Check for crypto errors */
490 if (crp->crp_etype) {
491 if (crp->crp_etype == EAGAIN) {
492 /* Reset the session ID */
493 if (ipsec_updateid(sav, &crp->crp_session, &cryptoid) != 0)
494 crypto_freesession(cryptoid);
495 xd->cryptoid = crp->crp_session;
496 CURVNET_RESTORE();
497 return (crypto_dispatch(crp));
498 }
499 ESPSTAT_INC(esps_noxform);
500 DPRINTF(("%s: crypto error %d\n", __func__, crp->crp_etype));
501 error = crp->crp_etype;
502 goto bad;
503 }
504
505 /* Shouldn't happen... */
506 if (m == NULL) {
507 ESPSTAT_INC(esps_crypto);
508 DPRINTF(("%s: bogus returned buffer from crypto\n", __func__));
509 error = EINVAL;
510 goto bad;
511 }
512 ESPSTAT_INC(esps_hist[sav->alg_enc]);
513
514 /* If authentication was performed, check now. */
515 if (esph != NULL) {
516 alen = xform_ah_authsize(esph);
517 AHSTAT_INC(ahs_hist[sav->alg_auth]);
518 /* Copy the authenticator from the packet */
519 m_copydata(m, m->m_pkthdr.len - alen, alen, aalg);
520 ptr = (caddr_t) (xd + 1);
521
522 /* Verify authenticator */
523 if (timingsafe_bcmp(ptr, aalg, alen) != 0) {
524 DPRINTF(("%s: authentication hash mismatch for "
525 "packet in SA %s/%08lx\n", __func__,
526 ipsec_address(&saidx->dst, buf, sizeof(buf)),
527 (u_long) ntohl(sav->spi)));
528 ESPSTAT_INC(esps_badauth);
529 error = EACCES;
530 goto bad;
531 }
532 m->m_flags |= M_AUTHIPDGM;
533 /* Remove trailing authenticator */
534 m_adj(m, -alen);
535 }
536
537 /* Release the crypto descriptors */
538 free(xd, M_XDATA), xd = NULL;
539 crypto_freereq(crp), crp = NULL;
540
541 /*
542 * Packet is now decrypted.
543 */
544 m->m_flags |= M_DECRYPTED;
545
546 /*
547 * Update replay sequence number, if appropriate.
548 */
549 if (sav->replay) {
550 u_int32_t seq;
551
552 m_copydata(m, skip + offsetof(struct newesp, esp_seq),
553 sizeof (seq), (caddr_t) &seq);
554 SECASVAR_LOCK(sav);
555 if (ipsec_updatereplay(ntohl(seq), sav)) {
556 SECASVAR_UNLOCK(sav);
557 DPRINTF(("%s: packet replay check for %s\n", __func__,
558 ipsec_sa2str(sav, buf, sizeof(buf))));
559 ESPSTAT_INC(esps_replay);
560 error = EACCES;
561 goto bad;
562 }
563 SECASVAR_UNLOCK(sav);
564 }
565
566 /* Determine the ESP header length */
567 if (sav->flags & SADB_X_EXT_OLD)
568 hlen = sizeof (struct esp) + sav->ivlen;
569 else
570 hlen = sizeof (struct newesp) + sav->ivlen;
571
572 /* Remove the ESP header and IV from the mbuf. */
573 error = m_striphdr(m, skip, hlen);
574 if (error) {
575 ESPSTAT_INC(esps_hdrops);
576 DPRINTF(("%s: bad mbuf chain, SA %s/%08lx\n", __func__,
577 ipsec_address(&sav->sah->saidx.dst, buf, sizeof(buf)),
578 (u_long) ntohl(sav->spi)));
579 goto bad;
580 }
581
582 /* Save the last three bytes of decrypted data */
583 m_copydata(m, m->m_pkthdr.len - 3, 3, lastthree);
584
585 /* Verify pad length */
586 if (lastthree[1] + 2 > m->m_pkthdr.len - skip) {
587 ESPSTAT_INC(esps_badilen);
588 DPRINTF(("%s: invalid padding length %d for %u byte packet "
589 "in SA %s/%08lx\n", __func__, lastthree[1],
590 m->m_pkthdr.len - skip,
591 ipsec_address(&sav->sah->saidx.dst, buf, sizeof(buf)),
592 (u_long) ntohl(sav->spi)));
593 error = EINVAL;
594 goto bad;
595 }
596
597 /* Verify correct decryption by checking the last padding bytes */
598 if ((sav->flags & SADB_X_EXT_PMASK) != SADB_X_EXT_PRAND) {
599 if (lastthree[1] != lastthree[0] && lastthree[1] != 0) {
600 ESPSTAT_INC(esps_badenc);
601 DPRINTF(("%s: decryption failed for packet in "
602 "SA %s/%08lx\n", __func__, ipsec_address(
603 &sav->sah->saidx.dst, buf, sizeof(buf)),
604 (u_long) ntohl(sav->spi)));
605 error = EINVAL;
606 goto bad;
607 }
608 }
609
610 /* Trim the mbuf chain to remove trailing authenticator and padding */
611 m_adj(m, -(lastthree[1] + 2));
612
613 /* Restore the Next Protocol field */
614 m_copyback(m, protoff, sizeof (u_int8_t), lastthree + 2);
615
616 switch (saidx->dst.sa.sa_family) {
617 #ifdef INET6
618 case AF_INET6:
619 error = ipsec6_common_input_cb(m, sav, skip, protoff);
620 break;
621 #endif
622 #ifdef INET
623 case AF_INET:
624 error = ipsec4_common_input_cb(m, sav, skip, protoff);
625 break;
626 #endif
627 default:
628 panic("%s: Unexpected address family: %d saidx=%p", __func__,
629 saidx->dst.sa.sa_family, saidx);
630 }
631 CURVNET_RESTORE();
632 return error;
633 bad:
634 CURVNET_RESTORE();
635 if (sav != NULL)
636 key_freesav(&sav);
637 if (m != NULL)
638 m_freem(m);
639 if (xd != NULL)
640 free(xd, M_XDATA);
641 if (crp != NULL)
642 crypto_freereq(crp);
643 return error;
644 }
645 /*
646 * ESP output routine, called by ipsec[46]_perform_request().
647 */
648 static int
esp_output(struct mbuf * m,struct secpolicy * sp,struct secasvar * sav,u_int idx,int skip,int protoff)649 esp_output(struct mbuf *m, struct secpolicy *sp, struct secasvar *sav,
650 u_int idx, int skip, int protoff)
651 {
652 IPSEC_DEBUG_DECLARE(char buf[IPSEC_ADDRSTRLEN]);
653 struct cryptodesc *crde = NULL, *crda = NULL;
654 struct cryptop *crp;
655 const struct auth_hash *esph;
656 const struct enc_xform *espx;
657 struct mbuf *mo = NULL;
658 struct xform_data *xd;
659 struct secasindex *saidx;
660 unsigned char *pad;
661 uint8_t *ivp;
662 uint64_t cntr;
663 crypto_session_t cryptoid;
664 int hlen, rlen, padding, blks, alen, i, roff;
665 int error, maxpacketsize;
666 uint8_t prot;
667
668 IPSEC_ASSERT(sav != NULL, ("null SA"));
669 esph = sav->tdb_authalgxform;
670 espx = sav->tdb_encalgxform;
671 IPSEC_ASSERT(espx != NULL, ("null encoding xform"));
672
673 if (sav->flags & SADB_X_EXT_OLD)
674 hlen = sizeof (struct esp) + sav->ivlen;
675 else
676 hlen = sizeof (struct newesp) + sav->ivlen;
677
678 rlen = m->m_pkthdr.len - skip; /* Raw payload length. */
679 /*
680 * RFC4303 2.4 Requires 4 byte alignment.
681 */
682 blks = MAX(4, espx->blocksize); /* Cipher blocksize */
683
684 /* XXX clamp padding length a la KAME??? */
685 padding = ((blks - ((rlen + 2) % blks)) % blks) + 2;
686
687 alen = xform_ah_authsize(esph);
688
689 ESPSTAT_INC(esps_output);
690
691 saidx = &sav->sah->saidx;
692 /* Check for maximum packet size violations. */
693 switch (saidx->dst.sa.sa_family) {
694 #ifdef INET
695 case AF_INET:
696 maxpacketsize = IP_MAXPACKET;
697 break;
698 #endif /* INET */
699 #ifdef INET6
700 case AF_INET6:
701 maxpacketsize = IPV6_MAXPACKET;
702 break;
703 #endif /* INET6 */
704 default:
705 DPRINTF(("%s: unknown/unsupported protocol "
706 "family %d, SA %s/%08lx\n", __func__,
707 saidx->dst.sa.sa_family, ipsec_address(&saidx->dst,
708 buf, sizeof(buf)), (u_long) ntohl(sav->spi)));
709 ESPSTAT_INC(esps_nopf);
710 error = EPFNOSUPPORT;
711 goto bad;
712 }
713 /*
714 DPRINTF(("%s: skip %d hlen %d rlen %d padding %d alen %d blksd %d\n",
715 __func__, skip, hlen, rlen, padding, alen, blks)); */
716 if (skip + hlen + rlen + padding + alen > maxpacketsize) {
717 DPRINTF(("%s: packet in SA %s/%08lx got too big "
718 "(len %u, max len %u)\n", __func__,
719 ipsec_address(&saidx->dst, buf, sizeof(buf)),
720 (u_long) ntohl(sav->spi),
721 skip + hlen + rlen + padding + alen, maxpacketsize));
722 ESPSTAT_INC(esps_toobig);
723 error = EMSGSIZE;
724 goto bad;
725 }
726
727 /* Update the counters. */
728 ESPSTAT_ADD(esps_obytes, m->m_pkthdr.len - skip);
729
730 m = m_unshare(m, M_NOWAIT);
731 if (m == NULL) {
732 DPRINTF(("%s: cannot clone mbuf chain, SA %s/%08lx\n", __func__,
733 ipsec_address(&saidx->dst, buf, sizeof(buf)),
734 (u_long) ntohl(sav->spi)));
735 ESPSTAT_INC(esps_hdrops);
736 error = ENOBUFS;
737 goto bad;
738 }
739
740 /* Inject ESP header. */
741 mo = m_makespace(m, skip, hlen, &roff);
742 if (mo == NULL) {
743 DPRINTF(("%s: %u byte ESP hdr inject failed for SA %s/%08lx\n",
744 __func__, hlen, ipsec_address(&saidx->dst, buf,
745 sizeof(buf)), (u_long) ntohl(sav->spi)));
746 ESPSTAT_INC(esps_hdrops); /* XXX diffs from openbsd */
747 error = ENOBUFS;
748 goto bad;
749 }
750
751 /* Initialize ESP header. */
752 bcopy((caddr_t) &sav->spi, mtod(mo, caddr_t) + roff,
753 sizeof(uint32_t));
754 SECASVAR_LOCK(sav);
755 if (sav->replay) {
756 uint32_t replay;
757
758 #ifdef REGRESSION
759 /* Emulate replay attack when ipsec_replay is TRUE. */
760 if (!V_ipsec_replay)
761 #endif
762 sav->replay->count++;
763 replay = htonl(sav->replay->count);
764
765 bcopy((caddr_t) &replay, mtod(mo, caddr_t) + roff +
766 sizeof(uint32_t), sizeof(uint32_t));
767 }
768 cryptoid = sav->tdb_cryptoid;
769 if (SAV_ISCTRORGCM(sav))
770 cntr = sav->cntr++;
771 SECASVAR_UNLOCK(sav);
772
773 /*
774 * Add padding -- better to do it ourselves than use the crypto engine,
775 * although if/when we support compression, we'd have to do that.
776 */
777 pad = (u_char *) m_pad(m, padding + alen);
778 if (pad == NULL) {
779 DPRINTF(("%s: m_pad failed for SA %s/%08lx\n", __func__,
780 ipsec_address(&saidx->dst, buf, sizeof(buf)),
781 (u_long) ntohl(sav->spi)));
782 m = NULL; /* NB: free'd by m_pad */
783 error = ENOBUFS;
784 goto bad;
785 }
786
787 /*
788 * Add padding: random, zero, or self-describing.
789 * XXX catch unexpected setting
790 */
791 switch (sav->flags & SADB_X_EXT_PMASK) {
792 case SADB_X_EXT_PRAND:
793 (void) read_random(pad, padding - 2);
794 break;
795 case SADB_X_EXT_PZERO:
796 bzero(pad, padding - 2);
797 break;
798 case SADB_X_EXT_PSEQ:
799 for (i = 0; i < padding - 2; i++)
800 pad[i] = i+1;
801 break;
802 }
803
804 /* Fix padding length and Next Protocol in padding itself. */
805 pad[padding - 2] = padding - 2;
806 m_copydata(m, protoff, sizeof(u_int8_t), pad + padding - 1);
807
808 /* Fix Next Protocol in IPv4/IPv6 header. */
809 prot = IPPROTO_ESP;
810 m_copyback(m, protoff, sizeof(u_int8_t), (u_char *) &prot);
811
812 /* Get crypto descriptors. */
813 crp = crypto_getreq(esph != NULL ? 2 : 1);
814 if (crp == NULL) {
815 DPRINTF(("%s: failed to acquire crypto descriptors\n",
816 __func__));
817 ESPSTAT_INC(esps_crypto);
818 error = ENOBUFS;
819 goto bad;
820 }
821
822 /* IPsec-specific opaque crypto info. */
823 xd = malloc(sizeof(struct xform_data), M_XDATA, M_NOWAIT | M_ZERO);
824 if (xd == NULL) {
825 crypto_freereq(crp);
826 DPRINTF(("%s: failed to allocate xform_data\n", __func__));
827 ESPSTAT_INC(esps_crypto);
828 error = ENOBUFS;
829 goto bad;
830 }
831
832 crde = crp->crp_desc;
833 crda = crde->crd_next;
834
835 /* Encryption descriptor. */
836 crde->crd_skip = skip + hlen;
837 crde->crd_len = m->m_pkthdr.len - (skip + hlen + alen);
838 crde->crd_flags = CRD_F_ENCRYPT;
839 crde->crd_inject = skip + hlen - sav->ivlen;
840
841 /* Encryption operation. */
842 crde->crd_alg = espx->type;
843 if (SAV_ISCTRORGCM(sav)) {
844 ivp = &crde->crd_iv[0];
845
846 /* GCM IV Format: RFC4106 4 */
847 /* CTR IV Format: RFC3686 4 */
848 /* Salt is last four bytes of key, RFC4106 8.1 */
849 /* Nonce is last four bytes of key, RFC3686 5.1 */
850 memcpy(ivp, sav->key_enc->key_data +
851 _KEYLEN(sav->key_enc) - 4, 4);
852 be64enc(&ivp[4], cntr);
853 if (SAV_ISCTR(sav)) {
854 /* Initial block counter is 1, RFC3686 4 */
855 /* XXXAE: should we use this only for first packet? */
856 be32enc(&ivp[sav->ivlen + 4], 1);
857 }
858
859 m_copyback(m, skip + hlen - sav->ivlen, sav->ivlen, &ivp[4]);
860 crde->crd_flags |= CRD_F_IV_EXPLICIT|CRD_F_IV_PRESENT;
861 }
862
863 /* Callback parameters */
864 xd->sp = sp;
865 xd->sav = sav;
866 xd->idx = idx;
867 xd->cryptoid = cryptoid;
868 xd->vnet = curvnet;
869
870 /* Crypto operation descriptor. */
871 crp->crp_ilen = m->m_pkthdr.len; /* Total input length. */
872 crp->crp_flags = CRYPTO_F_IMBUF | CRYPTO_F_CBIFSYNC;
873 if (V_async_crypto)
874 crp->crp_flags |= CRYPTO_F_ASYNC | CRYPTO_F_ASYNC_KEEPORDER;
875 crp->crp_buf = (caddr_t) m;
876 crp->crp_callback = esp_output_cb;
877 crp->crp_opaque = (caddr_t) xd;
878 crp->crp_session = cryptoid;
879
880 if (esph) {
881 /* Authentication descriptor. */
882 crda->crd_alg = esph->type;
883 crda->crd_skip = skip;
884 if (SAV_ISGCM(sav))
885 crda->crd_len = 8; /* RFC4106 5, SPI + SN */
886 else
887 crda->crd_len = m->m_pkthdr.len - (skip + alen);
888 crda->crd_inject = m->m_pkthdr.len - alen;
889 }
890
891 return crypto_dispatch(crp);
892 bad:
893 if (m)
894 m_freem(m);
895 key_freesav(&sav);
896 key_freesp(&sp);
897 return (error);
898 }
899 /*
900 * ESP output callback from the crypto driver.
901 */
902 static int
esp_output_cb(struct cryptop * crp)903 esp_output_cb(struct cryptop *crp)
904 {
905 struct xform_data *xd;
906 struct secpolicy *sp;
907 struct secasvar *sav;
908 struct mbuf *m;
909 crypto_session_t cryptoid;
910 u_int idx;
911 int error;
912
913 xd = (struct xform_data *) crp->crp_opaque;
914 CURVNET_SET(xd->vnet);
915 m = (struct mbuf *) crp->crp_buf;
916 sp = xd->sp;
917 sav = xd->sav;
918 idx = xd->idx;
919 cryptoid = xd->cryptoid;
920
921 /* Check for crypto errors. */
922 if (crp->crp_etype) {
923 if (crp->crp_etype == EAGAIN) {
924 /* Reset the session ID */
925 if (ipsec_updateid(sav, &crp->crp_session, &cryptoid) != 0)
926 crypto_freesession(cryptoid);
927 xd->cryptoid = crp->crp_session;
928 CURVNET_RESTORE();
929 return (crypto_dispatch(crp));
930 }
931 ESPSTAT_INC(esps_noxform);
932 DPRINTF(("%s: crypto error %d\n", __func__, crp->crp_etype));
933 error = crp->crp_etype;
934 m_freem(m);
935 goto bad;
936 }
937
938 /* Shouldn't happen... */
939 if (m == NULL) {
940 ESPSTAT_INC(esps_crypto);
941 DPRINTF(("%s: bogus returned buffer from crypto\n", __func__));
942 error = EINVAL;
943 goto bad;
944 }
945 free(xd, M_XDATA);
946 crypto_freereq(crp);
947 ESPSTAT_INC(esps_hist[sav->alg_enc]);
948 if (sav->tdb_authalgxform != NULL)
949 AHSTAT_INC(ahs_hist[sav->alg_auth]);
950
951 #ifdef REGRESSION
952 /* Emulate man-in-the-middle attack when ipsec_integrity is TRUE. */
953 if (V_ipsec_integrity) {
954 static unsigned char ipseczeroes[AH_HMAC_MAXHASHLEN];
955 const struct auth_hash *esph;
956
957 /*
958 * Corrupt HMAC if we want to test integrity verification of
959 * the other side.
960 */
961 esph = sav->tdb_authalgxform;
962 if (esph != NULL) {
963 int alen;
964
965 alen = xform_ah_authsize(esph);
966 m_copyback(m, m->m_pkthdr.len - alen,
967 alen, ipseczeroes);
968 }
969 }
970 #endif
971
972 /* NB: m is reclaimed by ipsec_process_done. */
973 error = ipsec_process_done(m, sp, sav, idx);
974 CURVNET_RESTORE();
975 return (error);
976 bad:
977 CURVNET_RESTORE();
978 free(xd, M_XDATA);
979 crypto_freereq(crp);
980 key_freesav(&sav);
981 key_freesp(&sp);
982 return (error);
983 }
984
985 static struct xformsw esp_xformsw = {
986 .xf_type = XF_ESP,
987 .xf_name = "IPsec ESP",
988 .xf_init = esp_init,
989 .xf_zeroize = esp_zeroize,
990 .xf_input = esp_input,
991 .xf_output = esp_output,
992 };
993
994 SYSINIT(esp_xform_init, SI_SUB_PROTO_DOMAIN, SI_ORDER_MIDDLE,
995 xform_attach, &esp_xformsw);
996 SYSUNINIT(esp_xform_uninit, SI_SUB_PROTO_DOMAIN, SI_ORDER_MIDDLE,
997 xform_detach, &esp_xformsw);
998