Home
last modified time | relevance | path

Searched refs:head2 (Results 1 – 25 of 46) sorted by relevance

12

/freebsd-13.1/sys/contrib/ck/include/
H A Dck_queue.h248 if ((head2)->cstqh_first != NULL) { \
251 (head1)->cstqh_last = (head2)->cstqh_last; \
252 CK_STAILQ_INIT((head2)); \
331 if ((head2)->cstqh_last == &(head2)->cstqh_first) \
342 (head1)->cstqh_last = (head2)->cstqh_last; \
343 CK_STAILQ_FIRST(head2) = swap_first; \
344 (head2)->cstqh_last = swap_last; \
347 if (CK_STAILQ_EMPTY(head2)) \
348 (head2)->cstqh_last = &(head2)->cstqh_first; \
430 (head1)->clh_first = (head2)->clh_first; \
[all …]
/freebsd-13.1/sys/sys/
H A Dqueue.h220 SLIST_INIT(head2); \
225 SLIST_INIT(head2); \
348 STAILQ_INIT((head2)); \
441 if (STAILQ_EMPTY(head2)) \
442 (head2)->stqh_last = &STAILQ_FIRST(head2); \
528 LIST_INIT(head2); \
535 LIST_INIT(head2); \
715 if (!TAILQ_EMPTY(head2)) { \
719 TAILQ_INIT((head2)); \
721 QMD_TRACE_HEAD(head2); \
[all …]
/freebsd-13.1/contrib/openbsm/compat/
H A Dqueue.h229 #define STAILQ_CONCAT(head1, head2) do { \ argument
230 if (!STAILQ_EMPTY((head2))) { \
231 *(head1)->stqh_last = (head2)->stqh_first; \
232 (head1)->stqh_last = (head2)->stqh_last; \
233 STAILQ_INIT((head2)); \
434 #define TAILQ_CONCAT(head1, head2, field) do { \ argument
435 if (!TAILQ_EMPTY(head2)) { \
436 *(head1)->tqh_last = (head2)->tqh_first; \
438 (head1)->tqh_last = (head2)->tqh_last; \
439 TAILQ_INIT((head2)); \
[all …]
/freebsd-13.1/crypto/openssh/openbsd-compat/
H A Dsys-queue.h411 #define SIMPLEQ_CONCAT(head1, head2) do { \ argument
412 if (!SIMPLEQ_EMPTY((head2))) { \
413 *(head1)->sqh_last = (head2)->sqh_first; \
414 (head1)->sqh_last = (head2)->sqh_last; \
415 SIMPLEQ_INIT((head2)); \
619 #define TAILQ_CONCAT(head1, head2, field) do { \ argument
620 if (!TAILQ_EMPTY(head2)) { \
621 *(head1)->tqh_last = (head2)->tqh_first; \
622 (head2)->tqh_first->field.tqe_prev = (head1)->tqh_last; \
623 (head1)->tqh_last = (head2)->tqh_last; \
[all …]
/freebsd-13.1/crypto/openssl/doc/man7/
H A Dossl_store.pod15 =head2 General
28 =head2 URI schemes and loaders
36 =head2 UI_METHOD and pass phrases
45 =head2 A generic call
H A DRAND_DRBG.pod25 =head2 Disclaimer
32 =head2 Typical Use Cases
79 =head2 The <master> DRBG instance
86 =head2 The <public> DRBG instance
90 =head2 The <private> DRBG instance
164 =head2 Automatic Reseeding
186 =head2 Manual Reseeding
211 =head2 Entropy Input vs. Additional Data
221 =head2 Configuring the Random Seed Source
234 =head2 Reseeding the master DRBG with automatic seeding enabled
[all …]
H A Ddes_modes.pod15 =head2 Electronic Codebook Mode (ECB)
40 =head2 Cipher Block Chaining Mode (CBC)
74 =head2 Cipher Feedback Mode (CFB)
121 =head2 Output Feedback Mode (OFB)
181 =head2 Triple ECB Mode
216 =head2 Triple CBC Mode
H A Dpassphrase-encoding.pod17 =head2 The general case
27 =head2 PKCS#12
79 =head2 OSSL_STORE
112 =head2 Creating new objects
122 =head2 Opening existing objects
H A DRSA-PSS.pod18 =head2 Signing and Verification
27 =head2 Key Generation
H A Dproxy-certificates.pod41 =head2 Enabling proxy certificate verification
55 =head2 Creating proxy certificates
133 =head2 Using proxy certs in applications
/freebsd-13.1/contrib/libucl/uthash/
H A Dutlist.h318 #define LL_CONCAT(head1,head2) \ argument
319 LL_CONCAT2(head1,head2,next)
321 #define LL_CONCAT2(head1,head2,next) \ argument
327 _tmp->next=(head2); \
329 (head1)=(head2); \
536 #define DL_CONCAT(head1,head2) \ argument
537 DL_CONCAT2(head1,head2,prev,next)
539 #define DL_CONCAT2(head1,head2,prev,next) \ argument
542 if (head2) { \
544 _tmp = (head2)->prev; \
[all …]
/freebsd-13.1/crypto/openssl/doc/man5/
H A Dx509v3_config.pod59 =head2 Basic Constraints.
84 =head2 Key Usage.
100 =head2 Extended Key Usage.
129 =head2 Subject Key Identifier.
211 =head2 Authority Info Access.
225 =head2 CRL distribution points
303 =head2 Certificate Policies.
362 =head2 Policy Constraints
373 =head2 Inhibit Any Policy
382 =head2 Name Constraints
[all …]
/freebsd-13.1/contrib/elftoolchain/common/
H A D_elftc.h94 #define STAILQ_CONCAT(head1, head2) do { \ argument
95 if (!STAILQ_EMPTY((head2))) { \
96 *(head1)->stqh_last = (head2)->stqh_first; \
97 (head1)->stqh_last = (head2)->stqh_last; \
98 STAILQ_INIT((head2)); \
/freebsd-13.1/crypto/openssl/doc/man3/
H A DX509V3_get_d2i.pod116 =head2 PKIX Certificate Extensions
145 =head2 Netscape Certificate Extensions
158 =head2 Miscellaneous Certificate Extensions
163 =head2 PKIX CRL Extensions
179 =head2 OCSP Extensions
189 =head2 Certificate Transparency Extensions
H A DASN1_STRING_TABLE_add.pod21 =head2 Types
26 =head2 Functions
H A DEVP_PKEY_CTX_set_rsa_pss_keygen_md.pod25 =head2 Signing and Verification
44 =head2 Key Generation
H A DOSSL_STORE_SEARCH.pod53 =head2 Types
64 =head2 Application Functions
79 =head2 Loader Functions
H A DEVP_PKEY_CTX_ctrl.pod187 =head2 RSA parameters
259 =head2 DSA parameters
274 =head2 DH parameters
311 =head2 DH key derivation function parameters
363 =head2 EC parameters
379 =head2 ECDH parameters
390 =head2 ECDH key derivation function parameters
424 =head2 Other parameters
H A DX509_LOOKUP_hash_dir.pod62 =head2 File Method
74 =head2 Hashed Directory Method
/freebsd-13.1/crypto/openssl/doc/man1/
H A Dciphers.pod410 =head2 SSL v3.0 cipher suites
431 =head2 TLS v1.0 cipher suites
448 =head2 AES cipher suites from RFC3268, extending TLS v1.0
484 =head2 SEED cipher suites from RFC4162, extending TLS v1.0
506 =head2 Additional Export 1024 and other cipher suites
512 =head2 Elliptic curve cipher suites.
532 =head2 TLS v1.2 cipher suites
589 =head2 ARIA cipher suites from RFC6209, extending TLS v1.2
617 =head2 Pre-shared keying (PSK) cipher suites
701 =head2 TLS v1.3 cipher suites
[all …]
H A Dgenpkey.pod115 =head2 RSA Key Generation Options
134 =head2 RSA-PSS Key Generation Options
159 =head2 EC Key Generation Options
182 =head2 DSA Parameter Generation Options
206 =head2 DH Parameter Generation Options
241 =head2 EC Parameter Generation Options
H A Dopenssl.pod79 =head2 Standard Commands
291 =head2 Message Digest Commands
373 =head2 Encoding and Cipher Commands
478 =head2 Common Options
488 =head2 Pass Phrase Options
/freebsd-13.1/contrib/unbound/dnscrypt/
H A Ddnscrypt.c579 struct config_strlist *head, *head2; in dnsc_parse_certs() local
607 for(head2 = cfg->dnscrypt_provider_cert_rotated; head2; head2 = head2->next) { in dnsc_parse_certs()
608 if(strcmp(head->str, head2->str) == 0) { in dnsc_parse_certs()
/freebsd-13.1/contrib/file/magic/Magdir/
H A Dperl51 0 search/1024/W \=head2\ Perl POD document text
52 0 search/1024/W \n\=head2\ Perl POD document text
/freebsd-13.1/crypto/openssl/crypto/bn/
H A DREADME.pod71 =head2 The BIGNUM structure
108 =head2 Low-level arithmetic operations
202 =head2 Size changes
213 =head2 Debugging

12