| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/WebAssembly/ |
| H A D | WebAssemblyInstrAtomics.td | 250 // sign-extending loads. 266 // zero-extending. 286 // Select zero-extending loads with no constant offset. 291 // Select sign-extending loads with no constant offset 298 // Zero-extending loads with constant offset 306 // Sign-extending loads with constant offset 634 // Truncating & zero-extending binary RMW patterns. 646 // Truncating & sign-extending binary RMW patterns. 676 // Truncating-extending binary RMWs with a constant offset 860 // Truncating & zero-extending ternary RMW patterns. [all …]
|
| H A D | WebAssemblyInstrMemory.td | 42 // Defines atomic and non-atomic loads, regular and extending. 145 // Select extending loads with no constant offset. 157 // Select extending loads with a constant offset. 180 // Select extending loads with just a constant offset. 204 // Resolve "don't care" extending loads to zero-extending loads. This is 205 // somewhat arbitrary, but zero-extending is conceptually simpler. 207 // Select "don't care" extending loads with no constant offset. 214 // Select "don't care" extending loads with a constant offset. 226 // Select "don't care" extending loads with just a constant offset.
|
| H A D | README.txt | 74 "returned" attribute through to MachineInstrs and extending the
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/Hexagon/ |
| H A D | HexagonInstrFormats.td | 121 let TSFlags{33-29} = opExtentBits; //Number of bits of range before extending. 123 let TSFlags{35-34} = opExtentAlign; // Alignment exponent before extending. 325 let TSFlags{27-23} = opExtentBits; //Number of bits of range before extending. 327 let TSFlags{29-28} = opExtentAlign; // Alignment exponent before extending.
|
| /freebsd-13.1/sys/fs/fuse/ |
| H A D | fuse_io.c | 494 bool direct_append, extending; in fuse_write_biobackend() local 508 extending = false; in fuse_write_biobackend() 517 extending = true; in fuse_write_biobackend() 538 if (extending) { in fuse_write_biobackend()
|
| /freebsd-13.1/crypto/openssl/doc/man1/ |
| H A D | ciphers.pod | 448 =head2 AES cipher suites from RFC3268, extending TLS v1.0 466 =head2 Camellia cipher suites from RFC4132, extending TLS v1.0 484 =head2 SEED cipher suites from RFC4162, extending TLS v1.0 496 =head2 GOST cipher suites from draft-chudov-cryptopro-cptls, extending TLS v1.0 589 =head2 ARIA cipher suites from RFC6209, extending TLS v1.2 610 =head2 Camellia HMAC-Based cipher suites from RFC6367, extending TLS v1.2 691 =head2 ChaCha20-Poly1305 cipher suites, extending TLS v1.2
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/Sparc/ |
| H A D | SparcInstr64Bit.td | 228 // All the 32-bit loads and stores are available. The extending loads are sign 229 // or zero-extending to 64 bits. The LDrr and LDri instructions load 32 bits 233 // SPARC v9 adds 64-bit loads as well as a sign-extending ldsw i32 loads. 273 // Sign-extending load of i32 into i64 is a new SPARC v9 instruction.
|
| /freebsd-13.1/sys/ufs/ufs/ |
| H A D | README.acls | 11 access control information with files and directories, extending the
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/RISCV/ |
| H A D | RISCVInstrInfoM.td | 83 // in fewer instructions than emitting DIVUW/REMUW then zero-extending the
|
| /freebsd-13.1/sys/contrib/device-tree/Bindings/sound/ |
| H A D | ti,j721e-cpb-ivi-audio.yaml | 14 extension board is extending the CPB audio support, decribed in:
|
| /freebsd-13.1/contrib/llvm-project/llvm/include/llvm/Target/GlobalISel/ |
| H A D | SelectionDAGCompat.td | 159 // sign-extending load is (G_SEXTLOAD x) in GlobalISel. Additionally,
|
| /freebsd-13.1/crypto/openssh/ |
| H A D | PROTOCOL.certkeys | 22 keys, by extending the existing ~/.ssh/authorized_keys mechanism to
|
| /freebsd-13.1/crypto/openssl/crypto/bn/ |
| H A D | README.pod | 68 debugging and extending the library. They are I<not> to be used by
|
| /freebsd-13.1/usr.sbin/ppp/ |
| H A D | README.nat | 122 The decision to add a command instead of extending 'set' or 'option' was
|
| /freebsd-13.1/contrib/llvm-project/llvm/include/llvm/Target/ |
| H A D | GenericOpcodes.td | 1028 // Same as G_INDEXED_LOAD except that the load performed is sign-extending, as with G_SEXTLOAD. 1036 // Same as G_INDEXED_LOAD except that the load performed is zero-extending, as with G_ZEXTLOAD.
|
| H A D | TargetSelectionDAG.td | 960 // extending load fragments.
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/M68k/ |
| H A D | M68kInstrData.td | 597 /// This group of Pseudos is analogues to the real x86 extending moves, but
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/ARC/ |
| H A D | ARCInstrFormats.td | 430 // x - Sign-extending. When set, short loads can be sign-extended to 32-bits.
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/PowerPC/ |
| H A D | PPCInstr64Bit.td | 1158 // Sign extending loads. 1214 // Zero extending loads.
|
| H A D | PPCInstrVSX.td | 3325 // LIWAX - This instruction is used for sign extending i32 -> i64. 3327 // zero-extending i32 to i64 (zext i32 -> i64). 3411 // LIWAX - This instruction is used for sign extending i32 -> i64. 3413 // zero-extending i32 to i64 (zext i32 -> i64).
|
| /freebsd-13.1/contrib/ncurses/doc/ |
| H A D | hackguide.doc | 32 reading for anyone who is interested in porting, extending or
|
| /freebsd-13.1/contrib/googletest/googlemock/docs/ |
| H A D | ForDummies.md | 190 [event listener API](../../googletest/docs/advanced.md#extending-google-test-by-handling-test-event…
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Target/SystemZ/ |
| H A D | SystemZInstrInfo.td | 626 // either way, but signed-extending loads have a short LH and a long LHY, 627 // while zero-extending loads have only the long LLH.
|
| /freebsd-13.1/crypto/heimdal/lib/kadm5/ |
| H A D | ChangeLog | 933 * bump_pw_expire.c: new function for extending password expiration
|
| /freebsd-13.1/crypto/heimdal/lib/wind/ |
| H A D | rfc3490.txt | 121 The IDNA specification solves the problem of extending the repertoire
|