| /freebsd-13.1/contrib/llvm-project/clang/include/clang/Tooling/ |
| H A D | CompilationDatabase.h | 46 CompileCommand(const Twine &Directory, const Twine &Filename, in CompileCommand() 48 : Directory(Directory.str()), Filename(Filename.str()), in CompileCommand() 52 std::string Directory; member 69 return LHS.Directory == RHS.Directory && LHS.Filename == RHS.Filename && 185 const Twine &Directory = "."); 195 loadFromBuffer(StringRef Directory, StringRef Data, std::string &ErrorMsg); 199 FixedCompilationDatabase(const Twine &Directory,
|
| H A D | CompilationDatabasePluginRegistry.h | 36 loadFromDirectory(StringRef Directory, std::string &ErrorMessage) = 0;
|
| /freebsd-13.1/contrib/libfido2/windows/ |
| H A D | build.ps1 | 87 New-Item -Type Directory ${BUILD} 88 New-Item -Type Directory ${BUILD}\32 89 New-Item -Type Directory ${BUILD}\32\dynamic 90 New-Item -Type Directory ${BUILD}\32\static 91 New-Item -Type Directory ${BUILD}\64 92 New-Item -Type Directory ${BUILD}\64\dynamic 93 New-Item -Type Directory ${BUILD}\64\static 94 New-Item -Type Directory ${OUTPUT} 147 New-Item -Type Directory .\${LIBRESSL} -ErrorAction Stop in Build() 160 New-Item -Type Directory .\${LIBCBOR} -ErrorAction Stop in Build() [all …]
|
| /freebsd-13.1/contrib/llvm-project/clang/lib/Tooling/ |
| H A D | CompilationDatabase.cpp | 80 findCompilationDatabaseFromDirectory(StringRef Directory, in findCompilationDatabaseFromDirectory() argument 84 while (!Directory.empty()) { in findCompilationDatabaseFromDirectory() 88 CompilationDatabase::loadFromDirectory(Directory, LoadErrorMessage)) in findCompilationDatabaseFromDirectory() 92 ErrorStream << "No compilation database found in " << Directory.str() in findCompilationDatabaseFromDirectory() 97 Directory = llvm::sys::path::parent_path(Directory); in findCompilationDatabaseFromDirectory() 107 StringRef Directory = llvm::sys::path::parent_path(AbsolutePath); in autoDetectFromSource() local 110 findCompilationDatabaseFromDirectory(Directory, ErrorMessage); in autoDetectFromSource() 326 const Twine &Directory) { in loadFromCommandLine() argument 372 const Twine &Directory, ArrayRef<std::string> CommandLine) { in FixedCompilationDatabase() argument 376 CompileCommands.emplace_back(Directory, StringRef(), in FixedCompilationDatabase() [all …]
|
| H A D | JSONCompilationDatabase.cpp | 166 loadFromDirectory(StringRef Directory, std::string &ErrorMessage) override { in loadFromDirectory() argument 167 SmallString<1024> JSONDatabasePath(Directory); in loadFromDirectory() 354 llvm::yaml::ScalarNode *Directory = nullptr; in parse() local 393 Directory = ValueString; in parse() 416 if (!Directory) { in parse() 426 Directory->getValue(DirectoryStorage)); in parse() 433 auto Cmd = CompileCommandRef(Directory, File, *Command, Output); in parse()
|
| /freebsd-13.1/contrib/ntp/ |
| H A D | README | 6 The ntp Distribution Base Directory 64 clockstuff Directory containing sources for miscellaneous programs 71 conf Directory containing a motley collection of 99 include Directory containing include header files used by most 104 kernel Directory containing sources for kernel programs such as 108 libntp Directory containing library source code used by most 111 ntpdate Directory containing sources for a program to set the 125 parse Directory containing files belonging to the generic 131 patches Directory containing patches already applied to this 135 scripts Directory containing scripts to build the configuration [all …]
|
| /freebsd-13.1/contrib/llvm-project/llvm/include/llvm/MC/ |
| H A D | MCDwarf.h | 234 Expected<unsigned> tryGetFile(StringRef &Directory, StringRef &FileName, 258 void setRootFile(StringRef Directory, StringRef FileName, in setRootFile() 261 CompilationDir = std::string(Directory); in setRootFile() 288 void maybeSetRootFile(StringRef Directory, StringRef FileName, in maybeSetRootFile() argument 293 Header.setRootFile(Directory, FileName, Checksum, Source); in maybeSetRootFile() 296 unsigned getFile(StringRef Directory, StringRef FileName, in getFile() argument 320 Expected<unsigned> tryGetFile(StringRef &Directory, StringRef &FileName, 325 unsigned getFile(StringRef &Directory, StringRef &FileName, 328 return cantFail(tryGetFile(Directory, FileName, Checksum, Source, 332 void setRootFile(StringRef Directory, StringRef FileName, in setRootFile() argument [all …]
|
| /freebsd-13.1/contrib/bmake/unit-tests/ |
| H A D | posix1.exp | 16 Directory and filename parts of local variables 56 Directory and filename parts of local variables 102 Directory and filename parts of local variables 149 Directory and filename parts of local variables
|
| /freebsd-13.1/contrib/llvm-project/llvm/include/llvm/Object/ |
| H A D | Minidump.h | 36 ArrayRef<minidump::Directory> streams() const { return Streams; } in streams() 39 ArrayRef<uint8_t> getRawStream(const minidump::Directory &Stream) const { in getRawStream() 165 ArrayRef<minidump::Directory> Streams, in MinidumpFile() 185 ArrayRef<minidump::Directory> Streams;
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Analysis/ |
| H A D | ModuleDebugInfoPrinter.cpp | 61 static void printFile(raw_ostream &O, StringRef Filename, StringRef Directory, in printFile() argument 67 if (!Directory.empty()) in printFile() 68 O << Directory << "/"; in printFile()
|
| /freebsd-13.1/usr.sbin/bsdconfig/share/media/ |
| H A D | directory.subr | 86 # Initializes the Directory media device. Returns success if the directory path 94 f_dprintf "Init routine called for Directory device. path=[%s]" \ 101 f_dprintf "Directory device already checked." 140 # Shuts down the Directory device. Return status should be ignored.
|
| /freebsd-13.1/contrib/llvm-project/clang/lib/Lex/ |
| H A D | ModuleMap.cpp | 178 auto *Directory = M->Directory; in findHeader() local 179 SmallString<128> FullPathName(Directory->getName()); in findHeader() 236 FullPathName.assign(Directory->getName()); in findHeader() 1040 Result->Directory = FrameworkDir; in inferFrameworkModule() 1433 const DirectoryEntry *Directory; member in clang::ModuleMapParser 1501 ModuleMapFile(ModuleMapFile), Directory(Directory), in ModuleMapParser() 1773 if (M->Directory != ActiveModule->Directory) in diagnosePrivateModules() 2011 ActiveModule->Directory = Directory; in parseModuleDecl() 2171 ModuleMapFileName += Directory->getName(); in parseExternModuleDecl() 2179 ? Directory in parseExternModuleDecl() [all …]
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/Support/ |
| H A D | FileCollector.cpp | 60 StringRef Directory = sys::path::parent_path(SrcPath); in updateWithRealPath() local 66 auto DirWithSymlink = CachedDirs.find(Directory); in updateWithRealPath() 70 if (sys::fs::real_path(Directory, RealPath)) in updateWithRealPath() 72 CachedDirs[Directory] = std::string(RealPath.str()); in updateWithRealPath()
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/MC/ |
| H A D | MCDwarf.cpp | 532 Expected<unsigned> MCDwarfLineTable::tryGetFile(StringRef &Directory, in tryGetFile() argument 550 MCDwarfLineTableHeader::tryGetFile(StringRef &Directory, in tryGetFile() argument 556 if (Directory == CompilationDir) in tryGetFile() 557 Directory = ""; in tryGetFile() 560 Directory = ""; in tryGetFile() 599 if (Directory.empty()) { in tryGetFile() 603 Directory = sys::path::parent_path(FileName); in tryGetFile() 604 if (!Directory.empty()) in tryGetFile() 612 if (Directory.empty()) { in tryGetFile() 616 DirIndex = llvm::find(MCDwarfDirs, Directory) - MCDwarfDirs.begin(); in tryGetFile() [all …]
|
| H A D | MCAsmStreamer.cpp | 64 void printDwarfFileDirective(unsigned FileNo, StringRef Directory, 1478 unsigned FileNo, StringRef Directory, StringRef Filename, in printDwarfFileDirective() argument 1483 if (!UseDwarfDirectory && !Directory.empty()) { in printDwarfFileDirective() 1485 Directory = ""; in printDwarfFileDirective() 1487 FullPathName = Directory; in printDwarfFileDirective() 1489 Directory = ""; in printDwarfFileDirective() 1495 if (!Directory.empty()) { in printDwarfFileDirective() 1496 PrintQuotedString(Directory, OS); in printDwarfFileDirective() 1509 unsigned FileNo, StringRef Directory, StringRef Filename, in tryEmitDwarfFileDirective() argument 1516 Table.tryGetFile(Directory, Filename, Checksum, Source, in tryEmitDwarfFileDirective() [all …]
|
| /freebsd-13.1/contrib/kyua/utils/process/ |
| H A D | executor.ipp | 56 /// Directory where the hook may place control files. 59 /// Directory to enter when running the subprocess. 75 /// \param control_directory Directory where control files can be placed. 76 /// \param work_directory Directory to enter when running the subprocess.
|
| /freebsd-13.1/contrib/llvm-project/llvm/lib/ObjectYAML/ |
| H A D | MinidumpEmitter.cpp | 172 static Directory layout(BlobAllocator &File, Stream &S) { in layout() 173 Directory Result; in layout() 234 std::vector<Directory> StreamDirectory(Obj.Streams.size()); in yaml2minidump()
|
| /freebsd-13.1/contrib/llvm-project/clang/lib/StaticAnalyzer/Core/ |
| H A D | HTMLDiagnostics.cpp | 62 std::string Directory; member in __anondc9f7b100111::HTMLDiagnostics 72 : DiagOpts(std::move(DiagOpts)), Directory(OutputDir), PP(pp), in HTMLDiagnostics() 216 if (std::error_code ec = llvm::sys::fs::create_directories(Directory)) { in ReportDiag() 218 << Directory << "': " << ec.message() << '\n'; in ReportDiag() 271 llvm::sys::path::append(Model, Directory, "report-%%%%%%.html"); in ReportDiag() 280 llvm::errs() << "warning: could not create file in '" << Directory in ReportDiag() 297 llvm::sys::path::append(Model, Directory, in ReportDiag()
|
| /freebsd-13.1/contrib/ntp/sntp/m4/ |
| H A D | ntp_dir_sep.m4 | 22 [Directory separator character, usually / or \\])
|
| /freebsd-13.1/usr.sbin/bsdconfig/usermgmt/include/ |
| H A D | messages.subr | 44 msg_create_home_directory="Create Home Directory" 48 msg_delete_home_directory="Delete Home Directory" 79 msg_home_directory="Home Directory"
|
| /freebsd-13.1/contrib/file/magic/Magdir/ |
| H A D | zip | 7 # Zip Central Directory record 104 # Zip End Of Central Directory record
|
| /freebsd-13.1/contrib/llvm-project/compiler-rt/lib/memprof/ |
| H A D | README.txt | 5 Directory structure:
|
| /freebsd-13.1/contrib/llvm-project/llvm/include/llvm/BinaryFormat/ |
| H A D | Minidump.h | 120 struct Directory { struct 124 static_assert(sizeof(Directory) == 12, ""); argument
|
| /freebsd-13.1/contrib/llvm-project/compiler-rt/lib/asan/ |
| H A D | README.txt | 5 Directory structure:
|
| /freebsd-13.1/crypto/heimdal/lib/wind/ |
| H A D | rfc4518.txt | 12 Lightweight Directory Access Protocol (LDAP): 29 The previous Lightweight Directory Access Protocol (LDAP) technical 40 A Lightweight Directory Access Protocol (LDAP) [RFC4510] matching 442 [RFC4510] Zeilenga, K., "Lightweight Directory Access Protocol 455 [RFC4517] Legg, S., Ed., "Lightweight Directory Access Protocol 482 Directory -- Overview of concepts, models and 487 Directory -- Models," X.501(1993) (also ISO/IEC 9594- 492 Directory: Selected Attribute Types", X.520(1993) (also 511 [RFC3377] Hodges, J. and R. Morgan, "Lightweight Directory Access 515 [RFC4515] Smith, M., Ed. and T. Howes, "Lightweight Directory
|