| /freebsd-12.1/contrib/llvm/include/llvm/Support/ |
| H A D | Error.h | 199 Error(std::unique_ptr<ErrorInfoBase> Payload) { in Error() argument 200 setPtr(Payload.release()); in Error() 274 reinterpret_cast<uintptr_t>(Payload) & in getPtr() 280 Payload = reinterpret_cast<ErrorInfoBase*>( in setPtr() 285 Payload = EI; in setPtr() 298 Payload = reinterpret_cast<ErrorInfoBase*>( in setChecked() 319 ErrorInfoBase *Payload = nullptr; variable 402 for (auto &Payload : E2List.Payloads) in join() 862 return Error(std::move(Payload)); in handleErrorImpl() 871 return handleErrorImpl(std::move(Payload), in handleErrorImpl() [all …]
|
| H A D | OnDiskHashTable.h | 432 const unsigned char *Payload; variable 494 const unsigned char *Payload, 498 Payload(Payload) {} in base_type() 538 return key_iterator(Payload, this->getNumEntries(), &this->getInfoObj()); in key_begin() 581 return data_iterator(Payload, this->getNumEntries(), &this->getInfoObj()); in data_begin() 603 Create(const unsigned char *Buckets, const unsigned char *const Payload, 610 Buckets, Payload, Base, InfoObj);
|
| /freebsd-12.1/contrib/compiler-rt/lib/esan/ |
| H A D | esan_hashtable.h | 62 bool lookup(const KeyTy &Key, DataTy &Payload); // Const except for Mutex. 63 bool add(const KeyTy &Key, const DataTy &Payload); 76 DataTy Payload; member 153 Entry->Payload.~DataTy(); in ~HashTable() 176 const KeyTy &Key, DataTy &Payload) { in lookup() argument 184 Payload = Entry->Payload; in lookup() 220 const KeyTy &Key, const DataTy &Payload) { in add() argument 240 Add->Payload = Payload; in add() 267 Entry->Payload.~DataTy(); in remove() 320 return HashPair(Entry->Key, Entry->Payload);
|
| /freebsd-12.1/contrib/llvm/tools/clang/include/clang/ASTMatchers/Dynamic/ |
| H A D | VariantValue.h | 124 class Payload { 126 virtual ~Payload(); 213 explicit VariantMatcher(std::shared_ptr<Payload> Value) in VariantMatcher() 222 std::shared_ptr<const Payload> Value;
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/ASTMatchers/Dynamic/ |
| H A D | VariantValue.cpp | 82 VariantMatcher::Payload::~Payload() {} in ~Payload() 84 class VariantMatcher::SinglePayload : public VariantMatcher::Payload { 115 class VariantMatcher::PolymorphicPayload : public VariantMatcher::Payload { 181 class VariantMatcher::VariadicOpPayload : public VariantMatcher::Payload {
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/Serialization/ |
| H A D | MultiOnDiskHashTable.h | 68 storage_type Buckets, storage_type Payload, storage_type Base, in OnDiskTable() 71 Table(NumBuckets, NumEntries, Buckets, Payload, Base, InfoObj) {} in OnDiskTable()
|
| /freebsd-12.1/lib/libc/net/ |
| H A D | protocols | 119 ipcomp 108 IPComp # IP Payload Compression Protocol 152 wesp 141 WESP # Wrapped Encapsulating Security Payload (RFC5840)
|
| /freebsd-12.1/contrib/llvm/include/llvm/IR/ |
| H A D | Constants.h | 293 static Constant *getNaN(Type *Ty, bool Negative = false, uint64_t Payload = 0); 295 APInt *Payload = nullptr); 297 APInt *Payload = nullptr);
|
| /freebsd-12.1/sys/dev/acpi_support/ |
| H A D | acpi_wmi_if.m | 113 # void* data: Payload
|
| /freebsd-12.1/contrib/llvm/include/llvm/ProfileData/ |
| H A D | InstrProfReader.h | 365 const unsigned char *const Payload,
|
| /freebsd-12.1/contrib/llvm/lib/ProfileData/ |
| H A D | InstrProfReader.cpp | 596 const unsigned char *Buckets, const unsigned char *const Payload, in InstrProfReaderIndex() argument 601 Buckets, Payload, Base, in InstrProfReaderIndex()
|
| /freebsd-12.1/contrib/llvm/lib/IR/ |
| H A D | Constants.cpp | 726 Constant *ConstantFP::getNaN(Type *Ty, bool Negative, uint64_t Payload) { in getNaN() argument 728 APFloat NaN = APFloat::getNaN(Semantics, Negative, Payload); in getNaN() 737 Constant *ConstantFP::getQNaN(Type *Ty, bool Negative, APInt *Payload) { in getQNaN() argument 739 APFloat NaN = APFloat::getQNaN(Semantics, Negative, Payload); in getQNaN() 748 Constant *ConstantFP::getSNaN(Type *Ty, bool Negative, APInt *Payload) { in getSNaN() argument 750 APFloat NaN = APFloat::getSNaN(Semantics, Negative, Payload); in getSNaN()
|
| /freebsd-12.1/contrib/llvm/include/llvm/ObjectYAML/ |
| H A D | WasmYAML.h | 183 yaml::BinaryRef Payload; member
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/CodeGen/ |
| H A D | CGDecl.cpp | 1024 llvm::APInt Payload(64, NaNPayload); in patternFor() local 1026 Payload = llvm::APInt::getSplat(BitWidth, Payload); in patternFor() 1027 return llvm::ConstantFP::getQNaN(Ty, NegativeNaN, &Payload); in patternFor()
|
| /freebsd-12.1/contrib/processor-trace/libipt/include/ |
| H A D | intel-pt.h.in | 298 /** SKL014: Intel(R) PT TIP.PGD May Not Have Target IP Payload. 543 /* Payload: 16 bits. Update last IP. */ 546 /* Payload: 32 bits. Update last IP. */ 549 /* Payload: 48 bits. Sign extend to full address. */ 552 /* Payload: 48 bits. Update last IP. */ 555 /* Payload: 64 bits. Full address. */
|
| /freebsd-12.1/contrib/llvm/lib/ObjectYAML/ |
| H A D | WasmYAML.cpp | 80 IO.mapRequired("Payload", Section.Payload); in sectionMapping()
|
| /freebsd-12.1/share/doc/IPv6/ |
| H A D | IMPLEMENTATION | 31 1.7 Jumbo Payload 891 1.7 Jumbo Payload 893 KAME supports the Jumbo Payload hop-by-hop option used to send IPv6 911 The IPv6 specification requires that the Jumbo Payload option must not 919 length field of the IPv6 header or in the value of the Jumbo Payload 929 packet is an actual Jumbo Payload, that is, its packet size is more 1946 RFC2393: IP Payload Compression Protocol (IPComp) 1986 RFC2394: IP Payload Compression Using DEFLATE
|
| /freebsd-12.1/contrib/file/magic/Magdir/ |
| H A D | archive | 1145 >>>30 string Payload/
|