| /freebsd-12.1/contrib/llvm/tools/clang/include/clang/Tooling/ |
| H A D | CompilationDatabase.h | 46 CompileCommand(Twine Directory, Twine Filename, in CompileCommand() 48 : Directory(Directory.str()), Filename(Filename.str()), in CompileCommand() 52 std::string Directory; member 64 return LHS.Directory == RHS.Directory && LHS.Filename == RHS.Filename && 179 Twine Directory = "."); 188 FixedCompilationDatabase(Twine Directory, ArrayRef<std::string> CommandLine);
|
| H A D | CompilationDatabasePluginRegistry.h | 37 loadFromDirectory(StringRef Directory, std::string &ErrorMessage) = 0;
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/Tooling/ |
| H A D | CompilationDatabase.cpp | 83 findCompilationDatabaseFromDirectory(StringRef Directory, in findCompilationDatabaseFromDirectory() argument 87 while (!Directory.empty()) { in findCompilationDatabaseFromDirectory() 91 CompilationDatabase::loadFromDirectory(Directory, LoadErrorMessage)) in findCompilationDatabaseFromDirectory() 95 ErrorStream << "No compilation database found in " << Directory.str() in findCompilationDatabaseFromDirectory() 100 Directory = llvm::sys::path::parent_path(Directory); in findCompilationDatabaseFromDirectory() 110 StringRef Directory = llvm::sys::path::parent_path(AbsolutePath); in autoDetectFromSource() local 113 findCompilationDatabaseFromDirectory(Directory, ErrorMessage); in autoDetectFromSource() 347 Twine Directory) { in loadFromCommandLine() argument 360 return llvm::make_unique<FixedCompilationDatabase>(Directory, StrippedArgs); in loadFromCommandLine() 383 CompileCommands.emplace_back(Directory, StringRef(), in FixedCompilationDatabase() [all …]
|
| H A D | JSONCompilationDatabase.cpp | 164 loadFromDirectory(StringRef Directory, std::string &ErrorMessage) override { in loadFromDirectory() argument 165 SmallString<1024> JSONDatabasePath(Directory); in loadFromDirectory() 303 llvm::yaml::ScalarNode *Directory = nullptr; in parse() local 330 Directory = ValueString; in parse() 362 if (!Directory) { in parse() 372 Directory->getValue(DirectoryStorage)); in parse() 378 auto Cmd = CompileCommandRef(Directory, File, *Command, Output); in parse()
|
| /freebsd-12.1/contrib/ntp/ |
| H A D | README | 6 The ntp Distribution Base Directory 64 clockstuff Directory containing sources for miscellaneous programs 71 conf Directory containing a motley collection of 99 include Directory containing include header files used by most 104 kernel Directory containing sources for kernel programs such as 108 libntp Directory containing library source code used by most 111 ntpdate Directory containing sources for a program to set the 125 parse Directory containing files belonging to the generic 131 patches Directory containing patches already applied to this 135 scripts Directory containing scripts to build the configuration [all …]
|
| /freebsd-12.1/contrib/llvm/include/llvm/MC/ |
| H A D | MCDwarf.h | 226 Expected<unsigned> tryGetFile(StringRef &Directory, StringRef &FileName, 259 void maybeSetRootFile(StringRef Directory, StringRef FileName, in maybeSetRootFile() argument 263 Header.CompilationDir = Directory; in maybeSetRootFile() 272 unsigned getFile(StringRef Directory, StringRef FileName, in getFile() argument 274 return cantFail(Header.tryGetFile(Directory, FileName, Checksum, Source)); in getFile() 293 Expected<unsigned> tryGetFile(StringRef &Directory, StringRef &FileName, 297 unsigned getFile(StringRef &Directory, StringRef &FileName, 300 return cantFail(tryGetFile(Directory, FileName, Checksum, Source, 304 void setRootFile(StringRef Directory, StringRef FileName, in setRootFile() argument 306 Header.CompilationDir = Directory; in setRootFile()
|
| H A D | MCStreamer.h | 783 unsigned EmitDwarfFileDirective(unsigned FileNo, StringRef Directory, 789 tryEmitDwarfFileDirective(FileNo, Directory, Filename, Checksum, 799 unsigned FileNo, StringRef Directory, StringRef Filename, 804 virtual void emitDwarfFile0Directive(StringRef Directory, StringRef Filename,
|
| /freebsd-12.1/contrib/llvm/lib/Analysis/ |
| H A D | ModuleDebugInfoPrinter.cpp | 57 static void printFile(raw_ostream &O, StringRef Filename, StringRef Directory, in printFile() argument 63 if (!Directory.empty()) in printFile() 64 O << Directory << "/"; in printFile()
|
| /freebsd-12.1/contrib/bmake/unit-tests/ |
| H A D | posix1.exp | 16 Directory and filename parts of local variables 56 Directory and filename parts of local variables 102 Directory and filename parts of local variables 149 Directory and filename parts of local variables
|
| /freebsd-12.1/usr.sbin/bsdconfig/share/media/ |
| H A D | directory.subr | 86 # Initializes the Directory media device. Returns success if the directory path 94 f_dprintf "Init routine called for Directory device. path=[%s]" \ 101 f_dprintf "Directory device already checked." 140 # Shuts down the Directory device. Return status should be ignored.
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/Lex/ |
| H A D | ModuleMap.cpp | 179 auto *Directory = M->Directory; in findHeader() local 180 SmallString<128> FullPathName(Directory->getName()); in findHeader() 237 FullPathName.assign(Directory->getName()); in findHeader() 1004 Result->Directory = FrameworkDir; in inferFrameworkModule() 1381 const DirectoryEntry *Directory; member in clang::ModuleMapParser 1449 ModuleMapFile(ModuleMapFile), Directory(Directory), in ModuleMapParser() 1720 if (M->Directory != ActiveModule->Directory) in diagnosePrivateModules() 1960 ActiveModule->Directory = Directory; in parseModuleDecl() 2120 ModuleMapFileName += Directory->getName(); in parseExternModuleDecl() 2128 ? Directory in parseExternModuleDecl() [all …]
|
| H A D | HeaderSearch.cpp | 479 if (CacheEntry.Directory && CacheEntry.Directory != getFrameworkDir()) in DoFrameworkLookup() 498 if (!CacheEntry.Directory) { in DoFrameworkLookup() 507 CacheEntry.Directory = getFrameworkDir(); in DoFrameworkLookup() 1003 if (CacheLookup.second.Directory && in LookupSubframeworkHeader() 1010 if (!CacheLookup.second.Directory) { in LookupSubframeworkHeader() 1019 CacheLookup.second.Directory = Dir; in LookupSubframeworkHeader()
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/StaticAnalyzer/Core/ |
| H A D | HTMLDiagnostics.cpp | 62 std::string Directory; member in __anon9c93332b0111::HTMLDiagnostics 74 : Directory(prefix), PP(pp), AnalyzerOpts(AnalyzerOpts), in HTMLDiagnostics() 167 if (std::error_code ec = llvm::sys::fs::create_directories(Directory)) { in ReportDiag() 169 << Directory << "': " << ec.message() << '\n'; in ReportDiag() 222 llvm::sys::path::append(Model, Directory, "report-%%%%%%.html"); in ReportDiag() 231 llvm::errs() << "warning: could not create file in '" << Directory in ReportDiag() 248 llvm::sys::path::append(Model, Directory, in ReportDiag()
|
| /freebsd-12.1/contrib/amd/ |
| H A D | ldap-id.ms | 38 Directory services such as X.500 [X500] or LDAP [RFC2251] are a natural 50 Directory servers implementing this schema SHOULD maintain the 271 M. Wahl, T. Howes, S. Kille, "Lightweight Directory Access 275 M. Wahl, A. Coulbeck, T. Howes, S. Kille, "Lightweight Directory 280 M. Wahl, S. Kille, T. Howes, "Lightweight Directory Access
|
| H A D | ldap-id.txt | 23 Directory services such as X.500 [X500] or LDAP [RFC2251] are a natural choice of 33 Directory servers implementing this schema SHOULD maintain the modifyTimestamp 292 M. Wahl, T. Howes, S. Kille, "Lightweight Directory Access 308 M. Wahl, A. Coulbeck, T. Howes, S. Kille, "Lightweight Directory 313 M. Wahl, S. Kille, T. Howes, "Lightweight Directory Access
|
| /freebsd-12.1/contrib/llvm/tools/clang/lib/AST/ |
| H A D | ExternalASTSource.cpp | 42 if (M.Directory) in ASTSourceDescriptor() 43 Path = M.Directory->getName(); in ASTSourceDescriptor()
|
| /freebsd-12.1/contrib/llvm/lib/MC/ |
| H A D | MCAsmStreamer.cpp | 228 StringRef Directory, 233 void emitDwarfFile0Directive(StringRef Directory, StringRef Filename, 1162 if (!UseDwarfDirectory && !Directory.empty()) { in printDwarfFileDirective() 1164 Directory = ""; in printDwarfFileDirective() 1166 FullPathName = Directory; in printDwarfFileDirective() 1168 Directory = ""; in printDwarfFileDirective() 1174 if (!Directory.empty()) { in printDwarfFileDirective() 1175 PrintQuotedString(Directory, OS); in printDwarfFileDirective() 1188 unsigned FileNo, StringRef Directory, StringRef Filename, in tryEmitDwarfFileDirective() argument 1215 void MCAsmStreamer::emitDwarfFile0Directive(StringRef Directory, in emitDwarfFile0Directive() argument [all …]
|
| H A D | MCDwarf.cpp | 534 Expected<unsigned> MCDwarfLineTable::tryGetFile(StringRef &Directory, in tryGetFile() argument 543 MCDwarfLineTableHeader::tryGetFile(StringRef &Directory, in tryGetFile() argument 548 if (Directory == CompilationDir) in tryGetFile() 549 Directory = ""; in tryGetFile() 552 Directory = ""; in tryGetFile() 589 if (Directory.empty()) { in tryGetFile() 593 Directory = sys::path::parent_path(FileName); in tryGetFile() 594 if (!Directory.empty()) in tryGetFile() 602 if (Directory.empty()) { in tryGetFile() 608 if (Directory == MCDwarfDirs[DirIndex]) in tryGetFile() [all …]
|
| /freebsd-12.1/usr.sbin/bsdconfig/usermgmt/include/ |
| H A D | messages.subr | 44 msg_create_home_directory="Create Home Directory" 48 msg_delete_home_directory="Delete Home Directory" 79 msg_home_directory="Home Directory"
|
| /freebsd-12.1/contrib/ntp/sntp/m4/ |
| H A D | ntp_dir_sep.m4 | 22 [Directory separator character, usually / or \\])
|
| /freebsd-12.1/crypto/heimdal/lib/wind/ |
| H A D | rfc4518.txt | 12 Lightweight Directory Access Protocol (LDAP): 29 The previous Lightweight Directory Access Protocol (LDAP) technical 40 A Lightweight Directory Access Protocol (LDAP) [RFC4510] matching 442 [RFC4510] Zeilenga, K., "Lightweight Directory Access Protocol 455 [RFC4517] Legg, S., Ed., "Lightweight Directory Access Protocol 482 Directory -- Overview of concepts, models and 487 Directory -- Models," X.501(1993) (also ISO/IEC 9594- 492 Directory: Selected Attribute Types", X.520(1993) (also 511 [RFC3377] Hodges, J. and R. Morgan, "Lightweight Directory Access 515 [RFC4515] Smith, M., Ed. and T. Howes, "Lightweight Directory
|
| /freebsd-12.1/contrib/tcsh/nls/C/ |
| H A D | set1 | 30 27 Directory stack not that deep 71 68 Directory stack empty
|
| /freebsd-12.1/contrib/compiler-rt/lib/asan/ |
| H A D | README.txt | 5 Directory structure:
|
| /freebsd-12.1/usr.sbin/bsdconfig/timezone/share/ |
| H A D | continents.subr | 58 # Directory name of each continent/ocean (in _PATH_ZONEINFO) 94 # name Directory name of continent/ocean as it appears in
|
| /freebsd-12.1/crypto/heimdal/doc/ |
| H A D | win2k.texi | 92 Install Windows, and create a new controller (Active Directory 109 Active Directory Domains and Trusts). 181 Start the @code{Active Directory Users and Computers} tool. Select the 191 the Active Directory LDAP catalog. When you create users by script you 305 @c @item Access to the Active Directory through LDAP:
|