<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="/rss.xsl.xml"?>
<rss version="2.0" xmlns:dc="http://purl.org/dc/elements/1.1/">
<channel>
    <title>Changes in Kconfig</title>
    <description></description>
    <language>en</language>
    <copyright>Copyright 2015</copyright>
    <generator>Java</generator><item>
        <title>a7f7f624 - treewide: replace &apos;---help---&apos; in Kconfig files with &apos;help&apos;</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#a7f7f624</link>
        <description>treewide: replace &apos;---help---&apos; in Kconfig files with &apos;help&apos;Since commit 84af7a6194e4 (&quot;checkpatch: kconfig: prefer &apos;help&apos; over&apos;---help---&apos;&quot;), the number of &apos;---help---&apos; has been graduallydecreasing, but there are still more than 2400 instances.This commit finishes the conversion. While I touched the lines,I also fixed the indentation.There are a variety of indentation styles found.  a) 4 spaces + &apos;---help---&apos;  b) 7 spaces + &apos;---help---&apos;  c) 8 spaces + &apos;---help---&apos;  d) 1 space + 1 tab + &apos;---help---&apos;  e) 1 tab + &apos;---help---&apos;    (correct indentation)  f) 1 tab + 1 space + &apos;---help---&apos;  g) 1 tab + 2 spaces + &apos;---help---&apos;In order to convert all of them to 1 tab + &apos;help&apos;, I ran thefollowing commend:  $ find . -name &apos;Kconfig*&apos; | xargs sed -i &apos;s/^[[:space:]]*---help---/\thelp/&apos;Signed-off-by: Masahiro Yamada &lt;masahiroy@kernel.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Sat, 13 Jun 2020 16:50:22 +0000</pubDate>
        <dc:creator>Masahiro Yamada &lt;masahiroy@kernel.org&gt;</dc:creator>
    </item>
<item>
        <title>ec8f24b7 - treewide: Add SPDX license identifier - Makefile/Kconfig</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#ec8f24b7</link>
        <description>treewide: Add SPDX license identifier - Makefile/KconfigAdd SPDX license identifiers to all Make/Kconfig files which: - Have no license information of any formThese files fall under the project license, GPL v2 only. The resulting SPDXlicense identifier is:  GPL-2.0-onlySigned-off-by: Thomas Gleixner &lt;tglx@linutronix.de&gt;Signed-off-by: Greg Kroah-Hartman &lt;gregkh@linuxfoundation.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Sun, 19 May 2019 12:07:45 +0000</pubDate>
        <dc:creator>Thomas Gleixner &lt;tglx@linutronix.de&gt;</dc:creator>
    </item>
<item>
        <title>a26c5fd7 - nl802154: add support for security layer</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#a26c5fd7</link>
        <description>nl802154: add support for security layerThis patch adds support for accessing mac802154 llsec implementationover nl802154. I added for a new Kconfig entry to provide thisfunctionality CONFIG_IEEE802154_NL802154_EXPERIMENTAL. This interface isstill in development. It provides to change security parameters andadd/del/dump entries of security tables. Later we can add also a get toget an entry by unique identifier.Cc: Phoebe Buckheister &lt;phoebe.buckheister@itwm.fraunhofer.de&gt;Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Signed-off-by: Marcel Holtmann &lt;marcel@holtmann.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Mon, 28 Sep 2015 07:00:25 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>ea81ac2e - ieee802154: create 6lowpan sub-directory</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#ea81ac2e</link>
        <description>ieee802154: create 6lowpan sub-directoryThis patch creates an 6lowpan sub-directory inside ieee802154.Additional we move all ieee802154 6lowpan relevant files intothis sub-directory instead of placing the 6lowpan related filesinside ieee802154.Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Signed-off-by: Marcel Holtmann &lt;marcel@holtmann.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Sun, 04 Jan 2015 16:10:53 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>9dc52d49 - ieee802154: handle config as menuconfig</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#9dc52d49</link>
        <description>ieee802154: handle config as menuconfigThis patch handles the IEEE802154 Kconfig entry as menuconfig.Furthermore we move this entry out of &quot;Network Options&quot; and put it into&quot;Networking&quot; where the other networking subsystems are. This requires amenuconfig entry like all other networking subsystems.Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Signed-off-by: Marcel Holtmann &lt;marcel@holtmann.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Wed, 31 Dec 2014 18:39:13 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>955d7fc9 - ieee802154: handle socket functionality as module</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#955d7fc9</link>
        <description>ieee802154: handle socket functionality as moduleThis patch makes the ieee802154 socket handling as module. Currentlythis is part of ieee802154 module. It pointed out that ieee802154 modulehas also two module_init/module_exit functions. One inside of core.c andthe other in af_ieee802154.c. This patch will also solve this issue byhandle the af_802154 as separate module.Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Signed-off-by: Marcel Holtmann &lt;marcel@holtmann.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Wed, 31 Dec 2014 18:39:08 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>2c6bed7c - 6lowpan: introduce new net/6lowpan directory</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#2c6bed7c</link>
        <description>6lowpan: introduce new net/6lowpan directoryThis patch moves generic code which is used by bluetooth and ieee8021546lowpan to a new net/6lowpan directory. This directory contains generic6LoWPAN code which is shared between bluetooth and ieee802154 MAC-Layer.This is the IPHC - &quot;IPv6 Header Compression&quot; format at the moment. Whichis described by RFC 6282 [0]. The BLTE 6LoWPAN draft describes that theIPHC is the same format like IEEE 802.15.4, see [1].Futuremore we can put more code into this directory which is sharedbetween BLTE and IEEE 802.15.4 6LoWPAN like RFC 6775 or the routingprotocol RPL RFC 6550.To avoid naming conflicts I renamed 6lowpan-y to ieee802154_6lowpan-yin net/ieee802154/Makefile.[0] http://tools.ietf.org/html/rfc6282[1] http://tools.ietf.org/html/draft-ietf-6lowpan-btle-12#section-3.2[2] http://tools.ietf.org/html/rfc6775[3] http://tools.ietf.org/html/rfc6550Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Acked-by: Jukka Rissanen &lt;jukka.rissanen@linux.intel.com&gt;Signed-off-by: Marcel Holtmann &lt;marcel@holtmann.org&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Fri, 11 Jul 2014 08:24:18 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>6092c79f - ieee802154: fix whitespace issues in Kconfig</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#6092c79f</link>
        <description>ieee802154: fix whitespace issues in KconfigThis patch fixes some whitespace issues in Kconfig files of IEEE802.15.4 subsytem.Signed-off-by: Alexander Aring &lt;alex.aring@gmail.com&gt;Signed-off-by: David S. Miller &lt;davem@davemloft.net&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Tue, 04 Mar 2014 18:01:18 +0000</pubDate>
        <dc:creator>Alexander Aring &lt;alex.aring@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>a53d34c3 - net: move 6lowpan compression code to separate module</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#a53d34c3</link>
        <description>net: move 6lowpan compression code to separate moduleIEEE 802.15.4 and Bluetooth networking stacks share 6lowpan compressioncode. Instead of introducing Makefile/Kconfig hacks, build this code asa separate module referenced from both ieee802154 and bluetooth modules.This fixes the following build error observed in some kernelconfigurations:net/built-in.o: In function `header_create&apos;: 6lowpan.c:(.text+0x166149): undefined reference to `lowpan_header_compress&apos;net/built-in.o: In function `bt_6lowpan_recv&apos;: (.text+0x166b3c): undefined reference to `lowpan_process_data&apos;Reported-by: Randy Dunlap &lt;rdunlap@infradead.org&gt;Signed-off-by: Dmitry Eremin-Solenikov &lt;dmitry_eremin@mentor.com&gt;Signed-off-by: David S. Miller &lt;davem@davemloft.net&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Tue, 14 Jan 2014 22:50:40 +0000</pubDate>
        <dc:creator>Dmitry Eremin-Solenikov &lt;dmitry_eremin@mentor.com&gt;</dc:creator>
    </item>
<item>
        <title>f4671a90 - net/ieee802154: remove depends on CONFIG_EXPERIMENTAL</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#f4671a90</link>
        <description>net/ieee802154: remove depends on CONFIG_EXPERIMENTALThe CONFIG_EXPERIMENTAL config item has not carried much meaning for awhile now and is almost always enabled by default. As agreed during theLinux kernel summit, remove it from any &quot;depends on&quot; lines in Kconfigs.CC: Alexander Smirnov &lt;alex.bluesman.smirnov@gmail.com&gt;CC: Dmitry Eremin-Solenikov &lt;dbaryshkov@gmail.com&gt;CC: &quot;David S. Miller&quot; &lt;davem@davemloft.net&gt;Signed-off-by: Kees Cook &lt;keescook@chromium.org&gt;Acked-by: David S. Miller &lt;davem@davemloft.net&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Tue, 02 Oct 2012 18:19:47 +0000</pubDate>
        <dc:creator>Kees Cook &lt;keescook@chromium.org&gt;</dc:creator>
    </item>
<item>
        <title>44331fe2 - IEEE802.15.4: 6LoWPAN basic support</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#44331fe2</link>
        <description>IEEE802.15.4: 6LoWPAN basic supportThis patch provides base support for transmission of IPv6 packets aswell as the formation of IPv6 link-local addresses and statelesslyautoconfigured addresses on top of IEEE 802.15.4 networks.For more information please look at the RFC4944 &quot;Compression Formatfor IPv6 Datagrams in Low Power and Losst Networks (6LoWPAN).Signed-off-by: Alexander Smirnov &lt;alex.bluesman.smirnov@gmail.com&gt;Signed-off-by: David S. Miller &lt;davem@davemloft.net&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Thu, 25 Aug 2011 02:34:42 +0000</pubDate>
        <dc:creator>Alexander Smirnov &lt;alex.bluesman.smirnov@gmail.com&gt;</dc:creator>
    </item>
<item>
        <title>9ec76716 - net: add IEEE 802.15.4 socket family implementation</title>
        <link>http://172.16.0.5:8080/history/linux-6.15/net/ieee802154/Kconfig#9ec76716</link>
        <description>net: add IEEE 802.15.4 socket family implementationAdd support for communication over IEEE 802.15.4 networks. This implementationis neither certified nor complete, but aims to that goal. This commit containsonly the socket interface for communication over IEEE 802.15.4 networks.One can either send RAW datagrams or use SOCK_DGRAM to encapsulate datainside normal IEEE 802.15.4 packets.Configuration interface, drivers and software MAC 802.15.4 implementation willfollow.Initial implementation was done by Maxim Gorbachyov, Maxim Osipov and PavelSmolensky as a research project at Siemens AG. Later the stack was heavilyreworked to better suit the linux networking model, and is now maitainedas an open project partially sponsored by Siemens.Signed-off-by: Dmitry Eremin-Solenikov &lt;dbaryshkov@gmail.com&gt;Signed-off-by: Sergey Lapin &lt;slapin@ossfans.org&gt;Signed-off-by: David S. Miller &lt;davem@davemloft.net&gt;

            List of files:
            /linux-6.15/net/ieee802154/Kconfig</description>
        <pubDate>Mon, 08 Jun 2009 12:18:48 +0000</pubDate>
        <dc:creator>Sergey Lapin &lt;slapin@ossfans.org&gt;</dc:creator>
    </item>
</channel>
</rss>
