<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="/rss.xsl.xml"?>
<rss version="2.0" xmlns:dc="http://purl.org/dc/elements/1.1/">
<channel>
    <title>Changes in timer.c</title>
    <description></description>
    <language>en</language>
    <copyright>Copyright 2015</copyright>
    <generator>Java</generator><item>
        <title>8a16b7a1 - General further adoption of SPDX licensing ID tags.</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#8a16b7a1</link>
        <description>General further adoption of SPDX licensing ID tags.Mainly focus on files that use BSD 3-Clause license.The Software Package Data Exchange (SPDX) group provides a specificationto make it easier for automated tools to detect and summarize well knownopensource licenses. We are gradually adopting the specification, notingthat the tags are considered only advisory and do not, in any way,superceed or replace the license texts.Special thanks to Wind River for providing access to &quot;The Duke ofHighlander&quot; tool: an older (2014) run over FreeBSD tree was useful as astarting point.

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Mon, 20 Nov 2017 19:49:47 +0000</pubDate>
        <dc:creator>Pedro F. Giffuni &lt;pfg@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>37743840 - Fix build on arm and mips.</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#37743840</link>
        <description>Fix build on arm and mips.

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Tue, 06 Aug 2013 15:49:18 +0000</pubDate>
        <dc:creator>Hiroki Sato &lt;hrs@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>7d26db17 - - Use time_uptime instead of time_second in data structures for</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#7d26db17</link>
        <description>- Use time_uptime instead of time_second in data structures for  PF_INET6 in kernel.  This fixes various malfunction when the wall time  clock is changed.  Bump __FreeBSD_version to 1000041.- Use clock_gettime(CLOCK_MONOTONIC_FAST) in userland utilities.MFC after:	1 month

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Mon, 05 Aug 2013 20:13:02 +0000</pubDate>
        <dc:creator>Hiroki Sato &lt;hrs@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>37241896 - - Improve interface list handling.  The rtadvd(8) now supports dynamically-</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#37241896</link>
        <description>- Improve interface list handling.  The rtadvd(8) now supports dynamically-  added/removed interfaces in a more consistent manner and reloading the  configuration file.- Implement burst unsolicited RA sending into the internal RA timer framework  when AdvSendAdvertisements and/or configuration entries are changed as  described in RFC 4861 6.2.4.  This fixes issues that make termination of the  rtadvd(8) daemon take very long time.  An interface now has three internal states, UNCONFIGURED, TRANSITIVE, or  CONFIGURED, and the burst unsolicited sending happens in TRANSITIVE.  See rtadvd.h for the details.- rtadvd(8) now accepts non-existent interfaces as well in the command line.- Add control socket support and rtadvctl(8) utility to show the RA information  in rtadvd(8).  Dumping by SIGUSR1 has been removed in favor of it.

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Sun, 17 Jul 2011 19:24:54 +0000</pubDate>
        <dc:creator>Hiroki Sato &lt;hrs@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>db82af41 - - Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#db82af41</link>
        <description>- Implement RDNSS and DNSSL options (RFC 6106, IPv6 Router Advertisement  Options for DNS Configuration) into rtadvd(8) and rtsold(8).  DNS  information received by rtsold(8) will go to resolv.conf(5) by  resolvconf(8) script.  This is based on work by J.R. Oldroyd (kern/156259)  but revised extensively[1].- rtadvd(8) now supports &quot;noifprefix&quot; to disable gathering on-link prefixes  from interfaces when no &quot;addr&quot; is specified[2].  An entry in rtadvd.conf  with &quot;noifprefix&quot; + no &quot;addr&quot; generates an RA message with no prefix  information option.- rtadvd(8) now supports RTM_IFANNOUNCE message to fix crashes when an  interface is added or removed.- Correct bogus ND_OPT_ROUTE_INFO value to one in RFC 4191.Reviewed by:	bz[1]PR:		kern/156259 [1]PR:		bin/152458 [2]

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Mon, 06 Jun 2011 03:06:43 +0000</pubDate>
        <dc:creator>Hiroki Sato &lt;hrs@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>784bddbc - Cleanup of userland __P use</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#784bddbc</link>
        <description>Cleanup of userland __P use

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Wed, 07 Nov 2007 10:53:41 +0000</pubDate>
        <dc:creator>Kevin Lo &lt;kevlo@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>72286081 - removed compilation warning</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#72286081</link>
        <description>removed compilation warningPR:	bin/71624

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Fri, 22 Oct 2004 07:31:12 +0000</pubDate>
        <dc:creator>SUZUKI Shinsuke &lt;suz@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>b6ed844f - reduce #ifdef.</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#b6ed844f</link>
        <description>reduce #ifdef.MFC after:	1 week

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Mon, 11 Aug 2003 15:51:54 +0000</pubDate>
        <dc:creator>Hajimu UMEMOTO &lt;ume@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>fa19f9be - KNF, correct typos and cleanup spaces.</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#fa19f9be</link>
        <description>KNF, correct typos and cleanup spaces.Obtained from:	KAMEMFC after:	1 week

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Fri, 08 Aug 2003 16:56:01 +0000</pubDate>
        <dc:creator>Hajimu UMEMOTO &lt;ume@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>1533bed0 - __FUNCTION__ --&gt; __func__</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#1533bed0</link>
        <description>__FUNCTION__ --&gt; __func__Obtained from:	KAMEMFC after:	1 week

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Fri, 08 Aug 2003 16:38:23 +0000</pubDate>
        <dc:creator>Hajimu UMEMOTO &lt;ume@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>0a5f3ef4 - Changed the behavior when an interface-direct prefix being advertised</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#0a5f3ef4</link>
        <description>Changed the behavior when an interface-direct prefix being advertisedwas removed from the kernel;Advertise the prefix with zero lifetimes rather than to remove the prefixfrom the prefix list to be advertised.This will help renumber a receiving host by deprecating the addressderived from the old prefix.Obtained from:	KAMEMFC after:	2 weeks

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Thu, 13 Jun 2002 16:59:31 +0000</pubDate>
        <dc:creator>Hajimu UMEMOTO &lt;ume@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>33841545 - Sync with recent KAME.</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#33841545</link>
        <description>Sync with recent KAME.This work was based on kame-20010528-freebsd43-snap.tgz and somecritical problem after the snap was out were fixed.There are many many changes since last KAME merge.TODO:  - The definitions of SADB_* in sys/net/pfkeyv2.h are still different    from RFC2407/IANA assignment because of binary compatibility    issue.  It should be fixed under 5-CURRENT.  - ip6po_m member of struct ip6_pktopts is no longer used.  But, it    is still there because of binary compatibility issue.  It should    be removed under 5-CURRENT.Reviewed by:	itojunObtained from:	KAMEMFC after:	3 weeks

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Mon, 11 Jun 2001 12:39:29 +0000</pubDate>
        <dc:creator>Hajimu UMEMOTO &lt;ume@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>ae326725 - make it easier to handle $FreeBSD$ tags (amount of diff matters).</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#ae326725</link>
        <description>make it easier to handle $FreeBSD$ tags (amount of diff matters).

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Sun, 21 Jan 2001 15:25:46 +0000</pubDate>
        <dc:creator>Jun-ichiro itojun Hagino &lt;itojun@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>b26e03e9 - Sync with latest KAME</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#b26e03e9</link>
        <description>Sync with latest KAMEObtained from:	KAME

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Wed, 05 Jul 2000 22:09:50 +0000</pubDate>
        <dc:creator>Kris Kennaway &lt;kris@FreeBSD.org&gt;</dc:creator>
    </item>
<item>
        <title>9a4365d0 - libipsec and IPsec related apps. (and some KAME related man pages)</title>
        <link>http://172.16.0.5:8080/history/freebsd-12.1/usr.sbin/rtadvd/timer.c#9a4365d0</link>
        <description>libipsec and IPsec related apps. (and some KAME related man pages)Reviewed by: freebsd-arch, cvs-committersObtained from: KAME project

            List of files:
            /freebsd-12.1/usr.sbin/rtadvd/timer.c</description>
        <pubDate>Thu, 06 Jan 2000 12:40:54 +0000</pubDate>
        <dc:creator>Yoshinobu Inoue &lt;shin@FreeBSD.org&gt;</dc:creator>
    </item>
</channel>
</rss>
