Lines Matching refs:IPv4

36 	1.12 IPv4 mapped address and IPv6 wildcard socket
69 3.2 IPv6-to-IPv4 header translator
169 * IPv4 compatible address is not supported.
176 RFC3056: Connection of IPv6 Domains via IPv4 Clouds
181 RFC3142: An IPv6-to-IPv4 transport relay translator
192 * IPv4 mapped address (3.7) and special behavior of IPv6 wildcard bind
233 * kame/openbsd completely disables IPv4 mapped address support.
234 * kame/netbsd makes IPv4 mapped address support off by default.
297 assumptions in BSD IPv4 network code. To implement the behavior in
308 consider a destination that has both IPv4 and IPv6 addresses but is
309 only reachable via IPv4. Since our getaddrinfo(3) prefers IPv6 by
806 If you would like to configure an IPv4-in-IPv6 tunnel with gif interface,
963 code in the way BSD IPv4 code is implemented, kernel stack may
977 IPv4 part (sys/netinet) remains untouched for compatibility.
978 Because of this, if you receive IPsec-over-IPv4 packet with massive
1010 independent. That is, they automatically chooses IPv4 or IPv6
1018 The current KAME has escaped from the IPv4 netinet logic. While
1076 1.12 IPv4 mapped address and IPv6 wildcard socket
1078 RFC2553/3493 describes IPv4 mapped address (3.7) and special behavior
1080 - Accept IPv4 connections by AF_INET6 wildcard bind socket.
1081 - Transmit IPv4 packet over AF_INET6 socket by using special form of
1089 between IPv4 and IPv6. You can perform wildcard bind on both of the address
1097 socket gets IPv4 conn.)
1129 If a server application would like to accept IPv4 and IPv6 connections,
1134 proper address family. IPv4 connections will be accepted by AF_INET socket,
1138 If you try to support IPv6 traffic only and would like to reject IPv4
1140 AF_INET6 listening socket. If the address is IPv4 mapped address, you may
1158 If you would like to use AF_INET6 socket for both IPv4 and IPv6 outgoing
1169 not recommend you to rely upon IPv4 mapped address.
1173 The platforms do not support IPv4 mapped address at all (both listening side
1189 The platform can be configured to support IPv4 mapped address/special
1194 Wildcard AF_INET6 socket grabs IPv4 connection if and only if the following
1196 - there's no AF_INET socket that matches the IPv4 connection
1197 - the AF_INET6 socket is configured to accept IPv4 traffic, i.e.
1204 KAME/FreeBSD3x supports outgoing connection to IPv4 mapped address
1205 (::ffff:10.1.1.1), if the node is configured to accept IPv4 connections
1221 The platform can be configured to support IPv4 mapped address/special AF_INET6
1239 Wildcard AF_INET6 socket grabs IPv4 connection if and only if the following
1241 - there's no AF_INET socket that matches the IPv4 connection
1242 - the AF_INET6 socket is configured to accept IPv4 traffic, i.e.
1245 You cannot bind(2) with IPv4 mapped address. This is a workaround for port
1251 traffic to IPv4 destination over AF_INET6 socket, using IPv4 mapped
1254 When getsockopt(IPV6_V6ONLY) is 1 for a socket, you cannot use IPv4 mapped
1260 which was derived from NRL IPv6/IPsec stack. We guess it supports IPv4 mapped
1269 Wildcard AF_INET6 socket grabs IPv4 connection if and only if the following
1271 - there's no AF_INET socket that matches the IPv4 connection
1275 KAME/BSDi4 supports connection initiation to IPv4 mapped address
1289 security reasons (if IPv4 traffic toward AF_INET6 wildcard bind is allowed,
1299 KAME/OpenBSD does not support connection initiation to IPv4 mapped address
1304 IPv4 mapped address support adds a big requirement to EVERY userland codebase.
1305 Every userland code should check if an AF_INET6 sockaddr contains IPv4
1312 - If a protocol on top of IPv4 is defined differently with IPv6, we need to be
1317 use EPSV/EPRT or PASV/PORT; /*IPv4*/
1322 The correct code, with consideration to IPv4 mapped address, would be:
1324 use EPSV/EPRT or PASV/PORT; /*IPv4*/
1325 else if (sa_family == AF_INET6 && IPv4 mapped address)
1326 use EPSV/EPRT or PASV/PORT; /*IPv4 command set on AF_INET6*/
1327 else if (sa_family == AF_INET6 && !IPv4 mapped address)
1334 - By enabling kernel support for IPv4 mapped address (outgoing direction),
1335 servers on the kernel can be hosed by IPv6 native packet that has IPv4
1336 mapped address in IPv6 header source, and can generate unwanted IPv4 packets.
1342 the use of IPv4 mapped addresses:
1343 - rshd/rlogind do not accept connections from IPv4 mapped address.
1344 This is to avoid malicious use of IPv4 mapped address in IPv6 native
1346 - ftp/ftpd assume that you are on dual stack network. IPv4 mapped address
1362 dual stack network. (3) KAME stack filters out IPv6 packets with IPv4
1368 things. For example, SIIT document asks IPv6-only (meaning no IPv4 code)
1369 node to be able to construct IPv4 IPsec headers. If a node knows how to
1370 construct IPv4 IPsec headers, that is not an IPv6-only node, it is a dual-stack
1415 Some of IPv6 transition technologies embed IPv4 address into IPv6 address.
1424 - IPv4 mapped address that embeds unspecified/multicast/loopback/broadcast
1425 IPv4 address (if they are in IPv6 native packet header, they are malicious)
1429 broadcast/private IPv4 address
1433 - IPv4 compatible address that embeds unspecified/multicast/loopback/broadcast
1434 IPv4 address (if they are in IPv6 native packet header, they are malicious).
1439 Also, since KAME does not support RFC1933/2893 auto tunnels, seeing IPv4
1442 If we see IPv6 packets with IPv4 mapped address (::ffff:0.0.0.0/96) in the
1444 that someone is trying to impersonate IPv4 peer. The packet should be dropped.
1744 We categorize IPv4/IPv6 translator into 4 types.
1748 island to an IPv4 host in the IPv4 ocean.
1751 it possible to establish a connection from an IPv4 host in the IPv4
1755 possible to establish a connection from an IPv4 host in an IPv4 island
1760 to an IPv4 host in an IPv4 island.
1769 toward that prefix to IPv4 destination.
1773 the connection will be relayed toward IPv4 destination 163.221.202.12.
1775 destination IPv4 node (163.221.202.12)
1777 | IPv4 tcp toward 163.221.202.12
1787 3.2 IPv6-to-IPv4 header translator
1844 IPsec module is implemented as "hooks" to the standard IPv4/IPv6
2003 IPv4 TOS field (or, IPv6 traffic class field) will be copied from inner